[Debugger] Takes a lot of CPU even when we do nothing

RESOLVED DUPLICATE of bug 1003664

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 1003664
3 years ago
3 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:
1. go to a simple page (like about:blank or http://everlong.org/).
2. open your CPU use monitor (eg: top on Linux). Observe the CPU usage is very low.
3. open the dev tools using ctrl-shift-k. Observe the CPU usage is still low.
4. switch to the Debugger tab. Observe the CPU usage is big (steadily ~35-45% on my computer).
5. observe that the CPU usage does not change even when you do nothing at all in Firefox.
6. close the dev tools, observe that the CPU usage drops back to a normal value.
For some reason, the only seems to happen on Linux, but we're not sure why.

Hopefully we can figure it out!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1003664
(Reporter)

Comment 2

3 years ago
I'd be happy to help testing things.
You need to log in before you can comment on or make changes to this bug.