webgl memory leak [webgl water demo]

RESOLVED DUPLICATE of bug 1137251

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1137251
3 years ago
3 years ago

People

(Reporter: Toady, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

Visit http://madebyevan.com/webgl-water/


Actual results:

Firefox within 30 seconds maxed out its memory usage @ 3.5gb but did not crash.


Expected results:

The webgl demo should have worked correctly with out the browsers memory usage maxing out.
(Reporter)

Updated

3 years ago
(Reporter)

Comment 1

3 years ago
Created attachment 8570986 [details]
Only affect firefox 36.0 on this profile.

Seems to be a setting in this old profile.
Does not happen in a clean profile or other Firefox versions.

Comment 2

3 years ago
I can reproduce the memory problem if HWA disabled.
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: WebGL
Ever confirmed: true
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Yeah, I wasn't 100% sure
Summary: webgl menory leak [webgl water demo] → webgl memory leak [webgl water demo]
(Reporter)

Comment 4

3 years ago
Finally got it to crash 

Current Firefox 37.0b1
https://crash-stats.mozilla.com/report/index/7b80a511-99ab-49e1-80cb-7f17e2150301

Can be produced on http://www.bongiovi.tw/experiments/webgl/blossom/ with H/W disabled
Can be produced on http://dev.miaumiau.cat/sph/ with H/W disabled
Locks up almost instant on http://www.spacegoo.com/wingsuit/# with H/W disabled
Can be produced on http://playcanv.as/p/JtL2iqIH with H/W disabled

Also the window detached from the window at one point see attached screenshot.
(Reporter)

Comment 5

3 years ago
Created attachment 8571024 [details]
screen detached.jpg
(Reporter)

Comment 6

3 years ago
This bug is resolved in 36.0.1 
This bug looks to be a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1137251
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137251
You need to log in before you can comment on or make changes to this bug.