[Youtube HTML5] 1080p60 video keeps re-buffering

RESOLVED FIXED

Status

()

Firefox
Untriaged
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: fireattack, Unassigned)

Tracking

(Blocks: 1 bug)

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150223185154

Steps to reproduce:

Open this video as an example: 

https://www.youtube.com/watch?v=-6xgKbQN1KA

Make sure MSE is enabled (default at 37 and above) and switch to 1080p60.


Actual results:

The video will buffer very fast (not all of the video because of dash, but irrelevant to problem). But after some time (LESS than the buffered portion), all the buffered video will be dropped and the video stops to re-buffer. Very annoying.


Expected results:

The video should play smoothly with high speed Internet.

I tested with new profile, the problem remains.

It does not appear in 38 or 39 though.

Comment 1

3 years ago
This looks like bug 1136138.

If I understand you correctly Ralph, according to https://bugzilla.mozilla.org/show_bug.cgi?id=1132825#c12, this will be resolved with beta 2?
Flags: needinfo?(giles)
(Reporter)

Comment 2

3 years ago
(In reply to Johan C from comment #1)
> This looks like bug 1136138.
> 
> If I understand you correctly Ralph, according to
> https://bugzilla.mozilla.org/show_bug.cgi?id=1132825#c12, this will be
> resolved with beta 2?

Thanks, I didn't find that bug when searching.

But anyway, beta 2 seems haven't be pushed to users (at least me) so I don't know if solved or not :(
Yes, it sounds like the same issue. Beta 2 won't be out until tomorrow, I think, although you can try integration builds with the fixes if you want to test today. E.g. https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-beta-win64/1425080200/firefox-37.0.en-US.win64.installer.exe
Blocks: 778617
Flags: needinfo?(giles)

Updated

3 years ago
Priority: -- → P1

Comment 4

3 years ago
I'm on Mac OS X 10.10.2, running Firefox 37b3, and the problem is still happening to me. After testing on several videos, I start out on 480p, and the video works just fine. Then, I switch the quality to 720p60, and it plays great. After switching to 1080p60, things go downhill for me. The first 2-4 seconds work great, then the video starts lagging, then buffering, but, oddly enough, the audio keeps going.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Closing presuming lack of reproduction since 37 beta 2 per comment #3.

Jacob, things not working for 1080p60, etc. sounds like a different issue. We're tracking related performance problems with high data rates in bug 1138967.
You need to log in before you can comment on or make changes to this bug.