Content text overlapping between box with larger height and section on specific Wikipedia page

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Andre Klapper, Unassigned)

Tracking

36 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Upstreamed from https://phabricator.wikimedia.org/T91098

1. Go to https://it.wikipedia.org/w/index.php?title=Kramer_contro_Kramer&oldid=70919012#Riconoscimenti
2. See that the box on the right overlaps with the section.
3. Problem does not happen on Google Chrome 41 or Opera 12.16 on Fedora 21.

Updated

3 years ago
Component: Untriaged → Layout
Product: Firefox → Core
Looks like that table is not being cleared past the float.

A somewhat minimal testcase might be helpful here; I haven't spent the time so far to figure out what layout the spec calls for in this situation, and that would be a lot more likely to happen with smaller HTML/CSS.
Keywords: qawanted, testcase-wanted
I have tested this issue on latest Firefox (44.0.2) release, latest Nightly (47.0a1) build and I could not reproduce it. The box on the right is not overlaps with the section. Chrome and Internet Explorer has the same behavior.

Firefox: 44.0.2 Build ID: 20160210153822
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Firefox: 47.0a1, Build ID: 20160222030212
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0

Considering the fact that the reporter is not currently accepting "needinfo" requests, I will mark this issue as resolved - wfm.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: qawanted, testcase-wanted
Resolution: --- → WORKSFORME
Looks like our behavior here changed between Firefox 41 and Firefox 42.  

Given that, presumably fixed by bug 478834, which was about a very similar (or exactly the same) situation of table overlapping a right-float and was fixed in 42.
Depends on: 478834
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.