[email] Remove placeholder text strings in templates

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jrburke, Assigned: jrburke)

Tracking

({late-l10n})

unspecified
2.2 S7 (6mar)
x86
Mac OS X
late-l10n

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
We occassionally get bugs like bug 1138562 that depending on how fast the l10n infrastructure starts up, we might temporarily show the placeholder strings we use in the templates, like NeW AccounT. Those are mostly there for us to confirm we have added l10n strings for things, and to give some context in the files.

However, it causes enough confusion we should just remove them now. This was discussed before, but I am having a hard time finding a pre-existing bug for it.
Yeah, I don't think we have a bug, but in some new code/refactoring you did, you nuked them or didn't create new stuff with them.  Definitely let's remove and ideally see if we can get uplifted since these type of bugs will tend to keep getting re-filed until the end of time if we don't.
Created attachment 8571544 [details] [review]
[gaia] jrburke:bug1138624-email-remove-placeholders > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8571544 - Flags: review?(bugmail)
Comment on attachment 8571544 [details] [review]
[gaia] jrburke:bug1138624-email-remove-placeholders > mozilla-b2g:master

r=asuth by inspection by confirming that the intra-line diffs showed that we were only eliminating CoOl StRiNgS or strings that shouldn't have been there.

Good catch on the aria implications of the compose button.  Maybe that should happen in a separate bug that we do try and v2.2 uplift if you don't want to v2.2 uplift this whole thing?  (I understand that we can still uplift strings but that they just want to be late-l10n.)
Attachment #8571544 - Flags: review?(bugmail) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Comment on attachment 8571544 [details] [review]
[gaia] jrburke:bug1138624-email-remove-placeholders > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Long-standing issue with our default strings for DOM content, but better served by removing them to avoid issues like bug 1138562.

[User impact] if declined:
Possible occasional cache issues as described in bug 1138562. Due to the missing l10n string for compose, the ARIA label for compose will likely be incorrect in non-English locales.

[Testing completed]:
Tested on device.

[Risk to taking this patch] (and alternatives if risky):
Very low. These strings are already replaced by the l10n infrastructure at runtime.

[String changes made]:
One string introduced because it was just missing when it should have been there. If this is approved for uplift, I will add late-l10n to the bug.
Attachment #8571544 - Flags: approval-gaia-v2.2?
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1138562

Updated

3 years ago
Keywords: late-l10n

Updated

3 years ago
Attachment #8571544 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/28f6a2af3ad7e69d3bcbc4ee8eb41874170d1d19

Note that this hit a minor conflict on uplift due to bug 825318 not being on v2.2 yet (so attachment_did_not_open_alert.html doesn't exist). If and when that gets approved for v2.2 (looks like that's not a certainty at this point), there's no way I'm going to remember to take this into account on the uplift, so I'd appreciate a branch-specific PR there.
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Flags: needinfo?(bugmail)
Target Milestone: --- → 2.2 S7 (6mar)
Flags: needinfo?(bugmail)
You need to log in before you can comment on or make changes to this bug.