[FTE] Rocketbar is visible in the Status Bar during the FTU.

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: yzen)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
When progressing through the FTU, the user can see the collapsed Rocketbar in the Status Bar, reading 'Search the Web.' The search bar is not selectable.

Notes:
-It is possible this issue was caused by the resolution to bug 1125131
-If the user goes through the FTU in different languages, the Rocketbar will display the translated string of 'FTU,' and not 'Search the Web' ('FTU' in Arabic, 'Erstbenutzung' in German)


Repro Steps:
1) Update a Flame to 20150302010223
2) In the FTU, look to the Status Bar at the top of the screen.

Actual:
The collapsed Rocketbar is visible in the Status Bar

Expected:
The Rocketbar is not visible during the FTU.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot, video clip (URL)
(Reporter)

Comment 1

4 years ago
This issue does NOT occur in Flame 2.2
The Rocketbar is not visible during the FTU.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150226125147
Gaia: 7512026a377271a0cade12d70846557f0bc7781c
Gecko: 4d0ef24554ca
Version: 39.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150226130547
Gaia: 2769db0e5fe75986ff9b16b39f63ec328eff62ff
Gecko: f0e534e2a829
Version: 39.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 7512026a377271a0cade12d70846557f0bc7781c
Gecko: f0e534e2a829

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 2769db0e5fe75986ff9b16b39f63ec328eff62ff
Gecko: 4d0ef24554ca

https://github.com/mozilla-b2g/gaia/compare/7512026a377271a0cade12d70846557f0bc7781c...2769db0e5fe75986ff9b16b39f63ec328eff62ff

caused by bug 1135805
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Yura, can you take a look at this please? Looks like the landing for bug 1135805 might have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(yzenevich)
Bug 1135805 got uplifted today. Lets back this out.
blocking-b2g: 3.0? → 2.2+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(yzenevich)
Resolution: --- → FIXED
Assignee: nobody → yzenevich
Blocks: 1135805
Target Milestone: --- → 2.2 S7 (6mar)
QA folks should be aware that this was backed out after today's 4pm PST nightlies started on both branches, so tomorrow's nightlies will be the first to reflect the backout on both branches.
Duplicate of this bug: 1138910
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The rocketbar is not available during the FTU.
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.