content-process crash when scrolling wired.com's new UI, with e10s enabled, sometimes inside of mozilla::ContainerState::ProcessDisplayItems(nsDisplayList*)

RESOLVED DUPLICATE of bug 1128751

Status

()

Core
Disability Access APIs
--
critical
RESOLVED DUPLICATE of bug 1128751
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({crash})

Trunk
All
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need to have run "gsettings set org.gnome.desktop.interface toolkit-accessibility true" to trigger this], URL)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-e27f2473-d5d5-4a31-ab46-2efaa2150302.
=============================================================
STR:
 1. Start Firefox with a fresh profile (with e10s enabled)
 2. Ctrl+Shift+M to put your tab into responsive-design-mode.
 3. Visit http://wired.com/
 4. Wait for the ad at the top of the page to load.

ACTUAL RESULTS: After the ad loads (above "TOP STORIES")

(Note: This reproduces nearly 100% of the time for me. When I can't reproduce, I can usually make it start reproducing again by Clearing Recent History (ctrl+shift+del) -- there may be a race involved somewhere, and having some piece of content cached locally lets us skip the race & avoid crashing.)

This never seems to crash in exactly the same place, though two of the crashes have been inside of mozilla::ContainerState::ProcessDisplayItems. (bp-9acd01ce-6261-4be3-80e8-f85de2150302 and bp-e27f2473-d5d5-4a31-ab46-2efaa2150302).

Crash reports:
bp-e27f2473-d5d5-4a31-ab46-2efaa2150302
bp-d37b5f46-e987-4b75-8437-0d2312150302
bp-9acd01ce-6261-4be3-80e8-f85de2150302
bp-89510349-b4aa-4733-b53d-054a52150302
bp-7d1c2c52-d3fb-47c6-970e-00eda2150302
bp-c5b6500e-5123-4775-a1d0-f722d2150302
bp-336f8652-2930-4600-9689-0de2a2150302
(Reporter)

Comment 1

3 years ago
I'm hitting this with up-to-date Nightly, version 39.0a1 (2015-03-02)
(Reporter)

Comment 2

3 years ago
In a debug build, I get this output:
{
[Parent 30367] ###!!! ASSERTION: no proxy for event!: 'Error', file /scratch/work/builds/mozilla-central/mozilla-central-11-11-01.13-56/mozilla/accessible/ipc/DocAccessibleParent.cpp, line 133
[Parent 30367] ###!!! ASSERTION: no proxy for event!: 'Error', file /scratch/work/builds/mozilla-central/mozilla-central-11-11-01.13-56/mozilla/accessible/ipc/DocAccessibleParent.cpp, line 133
[Parent 30367] ###!!! ASSERTION: adding child to unknown accessible: 'Error', file /scratch/work/builds/mozilla-central/mozilla-central-11-11-01.13-56/mozilla/accessible/ipc/DocAccessibleParent.cpp, line 38
IPDL protocol error: Handler for ShowEvent returned error code

###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x3E0004,name=PDocAccessible::Msg_ShowEvent) Processing error: message was deserialized, but the handler returned false (indicating failure)

[SNIP---dholbert---last 3 messages repeat several times---SNIP]

###!!! [Child][MessageChannel] Error: Channel error: cannot send/recv
}

Moreover, I can't reproduce if I disable the gsettings pref discussed in bug 1124821.

Hence, this is a dupe of bug 1124821. (Though perhaps easier to trigger than that bug, since it requires no interaction with the page.)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Layout → Disability Access APIs
Resolution: --- → DUPLICATE
Duplicate of bug: 1124821
(Reporter)

Comment 3

3 years ago
Sorry, meant to dupe to bug 1128751 (which is a followup of the bug that I'd mistakenly pasted in previous comment, bug 1124821).
Summary: crash when scrolling wired.com's new UI, with e10s enabled, sometimes inside of mozilla::ContainerState::ProcessDisplayItems(nsDisplayList*) → content-process crash when scrolling wired.com's new UI, with e10s enabled, sometimes inside of mozilla::ContainerState::ProcessDisplayItems(nsDisplayList*)
Duplicate of bug: 1128751
(Reporter)

Updated

3 years ago
Whiteboard: [need to have run "gsettings set org.gnome.desktop.interface toolkit-accessibility true" to trigger this]
You need to log in before you can comment on or make changes to this bug.