[B2G][SMS] Incorrect logic to identify the invalid port numbers in CDMA WAP Push.

RESOLVED FIXED in Firefox 39

Status

defect
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bevis, Assigned: bevis)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

This is a regression of bug 873351,
We should identify invalid port number of CDMA WAP Push with !== instead of === in [1].

A test case is also required to improve the test coverage.

[1] https://hg.mozilla.org/mozilla-central/rev/c8057e079f2d#l2.13
triage: major regression from re-factoring.
blocking-b2g: 2.2? → 2.2+
Hi Edgar,

Sorry to have this regression caused by bug 873351.

May I have your review for this fix?

Thanks!
Attachment #8571852 - Flags: review?(echen)
This is to improve the test coverage of CDMA Wap Push.

Hi Edgar,

May I have your review for this change?

Thanks!
Attachment #8571853 - Flags: review?(echen)
Attachment #8571852 - Flags: review?(echen) → review+
Comment on attachment 8571853 [details] [diff] [review]
Part 2 v1: Add Test Coverage for CDMA Wap Push. r=echen

Review of attachment 8571853 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thank you.
Attachment #8571853 - Flags: review?(echen) → review+
Attachment #8571852 - Attachment description: Part 1 v1: Fix the logic of checking invalid port in CDMA WAP Push. → Part 1 v1: Fix the logic of checking invalid port in CDMA WAP Push. r=echen
Attachment #8571853 - Attachment description: Part 2 v1: Add Test Coverage for CDMA Wap Push. → Part 2 v1: Add Test Coverage for CDMA Wap Push. r=echen
https://hg.mozilla.org/mozilla-central/rev/c6e3576bab27
https://hg.mozilla.org/mozilla-central/rev/82be6cb64840
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: 2.2 S8 (20mar) → 2.2 S7 (6mar)
Comment on attachment 8571852 [details] [diff] [review]
Part 1 v1: Fix the logic of checking invalid port in CDMA WAP Push. r=echen

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 873351
User impact if declined: Device can not identify CDMA Wap Push correctly if it is composed in multiple segments and received in reversed order.
Testing completed: Yes, new test case is included.
Risk to taking this patch (and alternatives if risky): No.
String or UUID changes made by this patch:No.
Attachment #8571852 - Flags: approval-mozilla-b2g37?
Comment on attachment 8571853 [details] [diff] [review]
Part 2 v1: Add Test Coverage for CDMA Wap Push. r=echen

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 873351
User impact if declined: Device can not identify CDMA Wap Push correctly if it is composed in multiple segments and received in reversed order.
Testing completed: Yes, new test case is included.
Risk to taking this patch (and alternatives if risky): No.
String or UUID changes made by this patch:No.
Attachment #8571853 - Flags: approval-mozilla-b2g37?
Attachment #8571852 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8571853 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.