Intellisense no longer works in generated Visual Studio project files

RESOLVED WORKSFORME

Status

()

Core
mach
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cpearce, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Something broke recently which made Intellisense not work in the VisualStudio project files generated by mach. I think this was in the last two weeks or so.

This is a shame, as Intellisense makes me appreciably more productive.
Fallout from bug 1122812?
Maybe dupe of 1138250?

Comment 3

3 years ago
In what way is intellisense broken?
Flags: needinfo?(cpearce)
In that it doesn't work at all.
You can't click on a function and jump to its definition.

Which isn't surprising seeing that there's no cpp file attached to the project, only headers.
The only source file attached is the unified file (which doesn't exist any longer by the time you've finished compiling)
Flags: needinfo?(cpearce)

Comment 5

3 years ago
You don't seem to be the original reporter, so that might be another observation.

Your observation seems to be bug 1138250 which this bug might be a duplicate of (as noted in comment 2). Please mark it as a duplicate if it is.
Flags: needinfo?(cpearce)
(Reporter)

Comment 6

3 years ago
I can't type part of a variable name and press CTRL+SPACE hand have the name autocomplete. I can 't highlight a variable and press F12 and jump to definition. I can't press CTRL+, and type a .cpp filename and have that file open. All these things worked a few weeks ago. Would love to have them back.
Flags: needinfo?(cpearce)

Comment 7

3 years ago
But do you have cpp-files in the project or do you have the same problem as mentioned in comment 4 and bug 1138250 (that bug have a small workaround patch you could try)?

Comment 8

3 years ago
... otherwise it might be helpful if you attached a representative .vcxproj-file
(In reply to andershol from comment #5)
> You don't seem to be the original reporter, so that might be another
> observation.
> 
> Your observation seems to be bug 1138250 which this bug might be a duplicate
> of (as noted in comment 2). Please mark it as a duplicate if it is.

I'm fairly certain it's the same problem as cpearce, he lodged the bug when I bitched about it :)

There's no cpp file, but typing Ctrl-K Ctrl-O in the header will open the source code, and then I can place my breakpoints
Created attachment 8576525 [details]
Screen Shot 2015-03-12 at 8.05.25 pm.png

screen shot of the file attached to a particul module and appearing in Solution Explorer

Comment 11

3 years ago
Sounds like a dupe to me.

Updated

3 years ago
Blocks: 1138250
Gonna call this fixed by bug 1138250.  Please reopen/refile if there are still problems.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.