Closed Bug 1138852 Opened 7 years ago Closed 7 years ago

[Nexus 5][Email]The Email page displays as blank when you launch Email app.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1118711
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: liuke, Unassigned)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 files)

[1.Description]:
[Nexus 5][Flame v2.2][Email] After you launch Email, the page can't display any content.
Found time:1:15
See attachment:115.mp4 and logcat_115.txt

[2.Testing Steps]: 
1.Launch Email.

[3.Expected Result]: 
1.The page should display "New Account" log in page.

[4.Actual Result]: 
1.The page displays as blank.

[5.Reproduction build]: 
Nexus-5 version:
Build ID               20150302162504
Gaia Revision          062d395273e70b8688a91b5a2b34c0cc7afc679f
Gaia Date              2015-03-02 22:12:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5a7cb3b9f78e
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150302.194900
Firmware Date          Mon Mar  2 19:49:17 EST 2015
Bootloader             HHZ12d

Flame 2.2 version:
Build ID               20150302002504
Gaia Revision          77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gaia Date              2015-02-27 16:35:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.042723
Firmware Date          Mon Mar  2 04:27:34 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150302010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.043726
Firmware Date          Mon Mar  2 04:37:37 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
10744

[8.Note]:
The bug does not exist in Flame 2.2.
[1.Description]:
[Nexus 5][Email] After you launch Email, the page can't display any content.
Attached file logcat_115.txt
Attached video 115.MP4
Thank you for the log!  This indicates the problem is that the worker thread is never starting up because of platform bug 1119157 which we are tracking in email as bug 1118711.  It's a little scary that this is now reproducing with a rate of 100%!  It's conceivable changes to email startup have made the probability of triggering a failure significantly greater, or it could be due to other platform changes.

The black screen is a new manifestation of the problem, but is simply due to us invalidating the HTML fast-cache because of all the recent changes in the email app.  If those changes had not happened the app would reuse the HTML cache but be entirely broken.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118711
Whiteboard: [2.2-nexus-5-l]
We still have this issue on and off.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The issue still happened on latest nexus-5-l.

Gaia-Rev        6a58c433c53c25e96e067a9b38bf1cc17307d5b2
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/22b4d45fe055
Build-ID        20150318162504
Version         37.0
Device-Name     hammerhead
FW-Release      5.0
Bug 1119157 which resolves bug 1118711 is not yet landed on v2.2 and is only very recently landed on trunk gecko (in https://bugzilla.mozilla.org/show_bug.cgi?id=1119157#c54).
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118711
You need to log in before you can comment on or make changes to this bug.