Closed Bug 1138897 Opened 8 years ago Closed 8 years ago

[UX] define standard add-on installation flow (including user interaction and errors)

Categories

(Firefox :: General, defect)

38 Branch
x86
macOS
defect
Not set
normal
Points:
5

Tracking

()

RESOLVED FIXED
Iteration:
40.2 - 27 Apr

People

(Reporter: designakt, Assigned: designakt)

References

Details

(Whiteboard: [ux])

Having everything take place inside the same doorhanger makes the Add-On-Install a lot less jarring (plus: no modals!). 
Define all states of the flow displayed in Attachment #8561741 [details] (https://bugzilla.mozilla.org/attachment.cgi?id=8561741)
These include:
- user switches Tab during process. (get user back on input)
- user closes Tab during process. (abort install)
- user navigates to other page in tab (continue install if same domain, abort if not?)
- error messages (http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#52)
Flags: qe-verify-
Flags: firefox-backlog+
Whiteboard: [ux]
Assignee: nobody → mjaritz
Status: NEW → ASSIGNED
Iteration: --- → 39.2 - 23 Mar
Points: --- → 5
Iteration: 39.2 - 23 Mar → 39.3 - 30 Mar
Iteration: 39.3 - 30 Mar → 40.1 - 13 Apr
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
Iteration: 40.1 - 13 Apr → 40.2 - 27 Apr
Blocks: 1120996
Update to include visual design and some string modifications:
https://bugzilla.mozilla.org/show_bug.cgi?id=1120996#c45
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This looks like the bug I just attempted to file as follows:
What did you do? (steps to reproduce) 	
Using Internet Explorer I went to xmarks.com and went to the plugins page, http://download.xmarks.com/download/all clicked on the Firefox extension download link, a dialog box pops up asking me to choose an application to open it and I choose Nightly. When I get around to looking at Nightly by hovering over the taskbar preview I see a message that Nightly did not load the extension "from this site". No site is shown and when I click on the preview pane to give Nightly focus, the message went away.	 
What happened? (actual results)
The extension didn't load, I briefly encountered a barely helpful message that said it didn't load and decided I wanted to dismiss it for no particular reason.
What should have happened? (expected results)
Instructions that stick around should help the user know what to do if in fact he wants to load the extension and perhaps more information should be given to help him decide if he wants to change his mind.
(In reply to Robert Claypool from comment #5)
> This looks like the bug I just attempted to file as follows:

Could you please file your encountered problem in a separate bug.
It seams you encountered a case where the new install flow that was implemented with this bug breaks. Having a dedicated bug for it would help us monitor it.
Please also mention your Firefox Version & Operating System in the new bug. Thanks
(If possible you could you also provide a screen capture of the encountered behavior. [LICEcap](http://www.cockos.com/licecap/) works best for that.)
You need to log in before you can comment on or make changes to this bug.