Python Gaia UI Test Tutorial Fixes

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Silne30, Assigned: Silne30)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
Make sure that the 7 part tutorial for running the Gaia UI Tests in python is up to date.
(Assignee)

Comment 1

3 years ago
Parts 1-3 have been completed.
Assignee: nobody → jdorlus
QA Whiteboard: [fxosqa-auto-s11]
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Finished Sections 4-7. This has been completed. 

https://etherpad.mozilla.org/gaiauidocsupdate
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-s11] → [fxosqa-auto-from-s11][fxosqa-auto-s12]
(Assignee)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-from-s11][fxosqa-auto-s12] → [fxosqa-auto-from-s11] [fxosqa-auto-s12]
(Assignee)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Status: REOPENED → NEW
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
I don't know if this can be found already on mdn (I don't think I could find it), but it would be nice if there would be very specific instruction on how to run gaia UI tests on b2g Desktop builds (on various platforms). Also for Mulet.

This is what I need to use to run b2g desktop tests on MacOSX:
gaia_clean mwargers$ DEVICE_DEBUG=1 && gaiatest --binary=/Users/mwargers/Downloads/B2G.app/Contents/MacOS/b2g-bin --profile /Users/mwargers/Downloads/B2G.app/Contents/Resources/gaia/profile/   --testvars /Users/mwargers/B2G/testvars_home.json --gecko-log=/Users/mwargers/B2G/gecko.log --restart --log-mach=bug1099985.log --log-mach-level=debug tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_delete_app.py


Also, it would be good to have very specific instructions on how to run gaia UI tests on your own built b2g desktop build (with your own built profile).
This is also useful when developers try to run gaia UI tests locally to hunt down failures caused by their patches (like bug 1118946).
Depends on: 1144182
You need to log in before you can comment on or make changes to this bug.