[RTL][Settings] Arabic: Wrong parenthesis displayed for Brazillian Portuguese keyboard in settings

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: timdream)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted image WrongParenthesis.png
Description:
Under Settings > Keyboard > Select Keyboards, the parenthesis is incorrectly displayed with Brazillian Portuguese.

Repro Steps:
1) Update a Flame to 20150303010233.
2) Set the device language in Arabic under Settings > Language.
3) Go to Settings > Keyboard > Select Keyboards.
4) Observe the parentheses in Portuguese.

Actual:
It is displayed as "(Portugues (do Brasil".

Expected:
It is displayed as "Portugues (do Brasil)".

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
Reporter

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: It is displayed as "(Portugues (do Brasil".

Device: Flame 2.2 (KK, 319mb, full flash)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Priority: -- → P3
Test case has been added in moztrap: https://moztrap.mozilla.org/manage/case/15968/
Flags: in-moztrap+
I believe this is an l10n issue. 
Flaggin rami so he can be aware of this and get a fix. thanks!
No longer blocks: settings-rtl
Component: Gaia::Settings → ar / Arabic
Flags: needinfo?(rami223)
Priority: P3 → --
Product: Firefox OS → Mozilla Localizations

Comment 4

4 years ago
I looked for this string but I was not able to find it!
Summary: [RTL][Settings] Wrong parenthesis displayed for Brazillian Portuguese under Keyboard setting → [RTL][Settings] Wrong parenthesis displayed for Arabic under Keyboard setting
Summary: [RTL][Settings] Wrong parenthesis displayed for Arabic under Keyboard setting → [RTL][Settings] Arabic: Wrong parenthesis displayed for Brazillian Portuguese keyboard in settings
It's not your string, it comes from the keyboard layout.
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/pt-BR.js#L4

Moving to Gaia::Keyboard for now, nothing you can do to fix this.
Component: ar / Arabic → Gaia::Keyboard
Flags: needinfo?(rami223)
Product: Mozilla Localizations → Firefox OS
(feel free to move to Gaia::Settings if you think it's more relevant)
Locale names are not hardcoded and are not localizable.

This is an RTL issue, and the bug component should be thus changed appropriately. The right approach to solve it is to embed every element in the locale list in a <bdi> tag.

See the similar bug 1140154.
My bad on this one! 
Nominating
blocking-b2g: --- → 2.2?
Priority: -- → P2

Comment 9

4 years ago
ni Tim for investigation
Flags: needinfo?(timdream)
Taking, will provide a fix per comment 7.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)
Component: Gaia::Keyboard → Gaia::Settings

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8587214 [details] [review]
[gaia] timdream:settings-layout-name-bdi > mozilla-b2g:master

I want to get rid off the outer <span> but that would have impact to style sheet, so this is the minimal fix ...
Attachment #8587214 - Flags: review?(arthur.chen)
Comment on attachment 8587214 [details] [review]
[gaia] timdream:settings-layout-name-bdi > mozilla-b2g:master

That makes sense. I can't imagine placing bdi in the selectors. r=me, thanks!
Attachment #8587214 - Flags: review?(arthur.chen) → review+
Comment on attachment 8587214 [details] [review]
[gaia] timdream:settings-layout-name-bdi > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature never implemented -- the fix here is to ensure the right presentation of LTR strings when the phone is set to RTL.
[User impact] if declined: As stated in STR for RTL locale.
[Testing completed]: manually tested and all tests passes
[Risk to taking this patch] (and alternatives if risky): Only a small DOM element change.
[String changes made]: None.
Attachment #8587214 - Flags: approval-gaia-v2.2?
Attachment #8587214 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2?(bbajaj)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment #8587214 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Updated

4 years ago
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], MGSEI-RTL-3F
Posted image verified screenshot
This issue is verified fixed on Flame 3.0 and 2.2. See attached screenshot for fixed behavior.

Device: Flame 3.0
BuildID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact]MGSEI-RTL-3F
Whiteboard: [3.0-Daily-Testing], MGSEI-RTL-3F → [3.0-Daily-Testing]
You need to log in before you can comment on or make changes to this bug.