Closed Bug 1139173 Opened 6 years ago Closed 6 years ago

build with musl libc fails in ipc/chromium/src/base/file_util.h: fts.h: no such file or directory

Categories

(Core :: IPC, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: felix.janda, Assigned: felix.janda)

Details

Attachments

(4 files, 1 obsolete file)

Build fails on linux systems with musl libc (http://musl-libc.org) in ipc/chromium/src/base/file_util.h because musl lacks fts.h.
Bugs 1113463 and 1114753 have indicated to me that a lot of the code is actually unused. Grepping the full tree for ScopedTempDir turned up nothing. With ScopedTempDir removed, file_utils doesn't need to be able to do recursive delete any more.
It looks like that even more of file_util could be removed.
Comment on attachment 8572209 [details] [diff] [review]
Remove ScopedTempDir and recursive file_util functions

Sorry for the large patch. I could split it into one patch removing ScopedTempDir and a patch for the rest.

Does the approach make sense?

The patch also changes the non-standard (and on musl non-existing) <sys/errno.h> to <errno.h>. Should this be split off?

Since I don't have access to the try server, I could only test on my system.
Attachment #8572209 - Flags: feedback?(nfroyd)
Comment on attachment 8572209 [details] [diff] [review]
Remove ScopedTempDir and recursive file_util functions

Review of attachment 8572209 [details] [diff] [review]:
-----------------------------------------------------------------

This all looks reasonable from a quick skim.  I would prefer the patch to be split up into three patches:

1. Switch to <errno.h>.
2. Remove ScopedTempDir.
3. Cleanup.

Thanks for doing this!
Attachment #8572209 - Flags: feedback?(nfroyd) → feedback+
Attachment #8594299 - Flags: review?(nfroyd)
Attachment #8594300 - Flags: review?(nfroyd)
This is the most non-trivial patch.

As can be seen from the changes to file_util.h, the changes are the following:
* Remove the unused CopyDirectory() functions
* Remove the unused recursive argument of Delete()
Attachment #8572209 - Attachment is obsolete: true
Attachment #8594301 - Flags: review?(nfroyd)
Attachment #8594299 - Flags: review?(nfroyd) → review+
Attachment #8594300 - Flags: review?(nfroyd) → review+
Attachment #8594301 - Flags: review?(nfroyd) → review+
Thanks for splitting those patches up!
Thanks for the review!

Could you do a try run for me? I don't have access to the try server.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/62325b792c42
https://hg.mozilla.org/mozilla-central/rev/1e75c69141ca
https://hg.mozilla.org/mozilla-central/rev/9b6b694dd82e
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.