[Search] Yahoo search result page does not appear with rocket bar search

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: daleharvey)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], )

Attachments

(2 attachments)

Reporter

Description

4 years ago
Description:
When Yahoo is set as the default search engine, the Yahoo search result page in Browser does not appear when the user types a keyword in the rocket bar. Instead, the main Yahoo page appears with the keyword filled in.

Repro Steps:
1) Update a Flame to 20150303010233.
2) Go to Settings > Search, and set Yahoo as search engine.
3) Tap the rocket bar, and enter any word.
4) Select any item listed under "YAHOO SEARCH", or press the search icon on the keyboard.

Actual:
Yahoo main screen appears with the search field filled with the typed word.

Expected:
Yahoo search result screen appears.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: logcat, video
http://youtu.be/gH9aIuyU8fg
Reporter

Comment 1

4 years ago
This issue does NOT reproduce on Flame 2.2.

Result: The Yahoo search result page appears on Browser.

Device: Flame 2.2 (KK, 319mb, full flash)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Dale, Ben, can you take a look?
Flags: needinfo?(dale)
Flags: needinfo?(bfrancis)
Assignee

Comment 3

4 years ago
Yeh will take, cheers
Assignee: nobody → dale
Flags: needinfo?(dale)
Flags: needinfo?(bfrancis)
Assignee

Comment 6

4 years ago
Comment on attachment 8572555 [details] [review]
[gaia] daleharvey:1139239 > mozilla-b2g:master

Picks up the correct url from http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/searchplugins/yahoo.xml?force=1

I added a version to the json file, I dont like the duplication but its far better than having the version duplicated and needing to be updated in every test file that needs to configure providers. 

I think we should look at removing it in a follow up but not block fixing the yahoo fix on it.
Attachment #8572555 - Flags: review?(kgrandon)
Comment on attachment 8572555 [details] [review]
[gaia] daleharvey:1139239 > mozilla-b2g:master

Seems fine to me, though I think we might just want to hard code the version inside the test support file instead?
Attachment #8572555 - Flags: review?(kgrandon) → review+
[Blocking Requested - why for this release]:

Nominating 3.0? since Yahoo is a key partner and search is not functioning properly compared to the other search engines.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee

Comment 9

4 years ago
Cheers Kevin, updated to address comments, good catch

Green try @ https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=cc6644e7e036
Landed in https://github.com/mozilla-b2g/gaia/commit/0017f2bbc63781a5409644b664d80ebaa1543653
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 10

4 years ago
Comment on attachment 8572555 [details] [review]
[gaia] daleharvey:1139239 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New Feature bug
[User impact] if declined: Key search partner misconfigured
[Testing completed]: Manual verification of URL
[Risk to taking this patch] (and alternatives if risky): little risk
[String changes made]: none
Attachment #8572555 - Flags: approval-gaia-v2.2?
Keywords: verifyme
ktucker, can we please verify this on 3.0? thanks!
blocking-b2g: 3.0? → 3.0+
Flags: needinfo?(ktucker)
This issue is verified as fixed on Flame 3.0

Performing a search with Yahoo set as the default search provider works as expected. The user is shown the actual search results.

Environmental Variables:
Device: Flame 3.0(Full Flash)(KK)(319mb)
BuildID: 20150309010232
Gaia: fea83511df9ccba64259346bc02ebf2c417a12c2
Gecko: eab4a81e4457
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker) → needinfo?(pbylenga)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Attachment #8572555 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
blocking-b2g: 3.0+ → 2.2+
Keywords: verifyme
Target Milestone: --- → 2.2 S7 (6mar)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Assignee

Updated

4 years ago
Duplicate of this bug: 1148300
Assignee

Comment 14

4 years ago
Not sure why this was set as 2.2 unnaffected, has approval so uplifted to 2.2

https://github.com/mozilla-b2g/gaia/commit/bb2afb1a183deaa5fd6a86e5bdcd4e21f785a0c0
Verifed with below build, thanks!

Build ID               20150329162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.200030
Firmware Date          Sun Mar 29 20:00:41 EDT 2015
Bootloader             L1TC000118D0
Per Comment 12 & Comment 15 ,clear "verifyme".
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.