Shortcut commands from menu panel are not visible on hover with High Contrast themes

VERIFIED FIXED in Firefox 38

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Assigned: Paenglab)

Tracking

39 Branch
Firefox 39
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox38+ verified, firefox39 verified)

Details

Attachments

(1 attachment)

Note: this is a follow-up for Bug 1079098

Reproducible on: 
Firefox 39.0a1 on Windows 8.1 64bit

STR
1.Right click on desktop -> Personalize.
2.Select High Contrast Black (or High Contrast White)
3.Launch Firefox with clean profile.
4.Click on Menu Panel.
5.Open Web Development Tools.
6.Hover over one of the tools from the list.

AR
The shortcut commands are not visible on hover.

ER 
The shortcut commands are clearly visible on hover.

Additional notes:
 - This issue is reproducible on Firefox 39.0a1 (2015-03-03) using Windows 8.1 64bit with High Contrast Black and High Contrast White
 - I am attaching 2 screenshots:
	 High Contrast Black:	http://i.imgur.com/9tdvr7g.jpg
	 High Contrast White: 	http://i.imgur.com/nGsgQLX.jpg
(Assignee)

Comment 1

3 years ago
Created attachment 8573490 [details] [diff] [review]
shortcutHover.patch

This sets also for the shortcut the highlight color on hover.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8573490 - Flags: review?(gijskruitbosch+bugs)

Updated

3 years ago
Attachment #8573490 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 2

3 years ago
... and I was planning to land this straight away, but fx-team is closed. :-\
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/d6580fa1125f
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/d6580fa1125f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
I was able to reproduce this issue on Firefox 39.0a1 (2015-03-04) using Windows 8.1 x64.

Verified fixed on Firefox 39.0a1 (2015-03-08) using Windows 8.1 x64 with High Contrast Black and High Contrast White.
Status: RESOLVED → VERIFIED
status-firefox39: fixed → verified

Updated

3 years ago
Blocks: 1079098
status-firefox38: --- → ?
Tracking for 38 based on comments in bug 1079098.
status-firefox38: ? → affected
tracking-firefox38: --- → +
Comment on attachment 8573490 [details] [diff] [review]
shortcutHover.patch

[Triage Comment]

Approving this for uplift to 38 since it goes with the second patch in bug 1079098, based on https://bugzilla.mozilla.org/show_bug.cgi?id=1079098#c39
Attachment #8573490 - Flags: approval-mozilla-aurora+
I was able to reproduce this issue on Firefox 38.0a2 (2015-03-16) using Windows 8.1 32bit.

Verified fixed on Firefox 38.0a2 (2015-03-18) using Windows 8.1 32bit with High Contrast Black and High Contrast White.
status-firefox38: fixed → verified
You need to log in before you can comment on or make changes to this bug.