Closed Bug 1139486 Opened 5 years ago Closed 5 years ago

test_sms_auto_save_draft.py failing consistently

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dharris, Unassigned)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Attached file SMSautosave results
The test (test_sms_auto_save_draft.py) is failing consistently in today's nonsmoke2 suite. 
The keyboard appears as though it is trying to dismiss, but does not and is causing issues.

Traceback (most recent call last):
   File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette_test.py", line 283, in run
     testMethod()
   File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_auto_save_draft.py", line 41, in test_sms_auto_save_draft
     cards_view.wait_for_cards_view()
  File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/gaiatest/apps/system/regions/cards_view.py", line 91, in wait_for_cards_view
     lambda m: cards_view.get_attribute('class') == 'active')
   File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/wait.py", line 143, in until
     cause=last_exc)
 TEST-INFO took 119051ms

Repro Rate: 10/10
Video of the issue: http://youtu.be/eqkXKL8XdZo
Reproducing manually? No

First Failing:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/64/testReport/junit/%28root%29/test_sms_auto_save_draft_py%20TestSmsAutoSaveDrafts_test_sms_auto_save_draft/test_sms_auto_save_draft_py_TestSmsAutoSaveDrafts_test_sms_auto_save_draft/history/

Device firmware (base)	L1TC100118D0
Device firmware (date)	04 Mar 2015 01:20:03
Device firmware (incremental)	eng.cltbld.20150304.041952
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	03 Mar 2015 13:58:43
Gaia revision	3fc0ac309f5f
Gecko build	20150304010324
Gecko revision	c5b90c003be8
Gecko version	39.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Derek, is this still an issue? This seems to be working for me on current master, while running the test.
Flags: needinfo?(dharris)
I did have 9/10 pass, but then after running the case again I got 10/10 pass. Seems like the issue is no longer occuring.
Flags: needinfo?(dharris)
Marking worksforme, then.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.