external dtd files that have xml version don't load

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: Brade, Assigned: nisheeth_mozilla)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
in order to get my xul files to load with external dtd files I had to remove the
xml version line from each of the external dtd files.  See rev 1.17 of mozilla/
editor/ui/dialogs/content/EdHLineProps.xul and rev 1.1 of mozilla/editor/ui/
dialogs/locale/en-US/EditorHLineProps.dtd.  Revision 1.18 should work with rev
1.1 of its dtd file.

It should be ok to have <?xml version="1.0"?> in the external dtd file.
(Reporter)

Updated

20 years ago
Version: other
(Reporter)

Comment 1

20 years ago
cc tao@netscape.com
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 2

20 years ago
Accepting bug and setting milestone to M12...
(Assignee)

Comment 3

20 years ago
James, it seems like this is a bug in expat.  The attached .xml/.dtd file should
work, but we end up getting an "error in processing external entity reference"
error from expat.  Please take a look into this.  Thanks a lot.
(Assignee)

Comment 4

20 years ago
Created attachment 1428 [details]
bug11396.xml
(Assignee)

Comment 5

20 years ago
Created attachment 1429 [details]
bug11396.dtd

Comment 6

20 years ago
This is not a bug.  A TextDecl has to include an EncodingDecl. See production 77
of the XML Recommendation.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
(Assignee)

Comment 7

20 years ago
James is right.  Kathy, according to the XML spec., you have to specify the
encoding in the text declaration as follows: <?xml version="1.0"
encoding="ISO-8859-1"?>.  Or, you can leave the text decl out.

Marking this bug invalid.

Comment 8

20 years ago
Why "ISO-8859-1" instead of "UTF-8"?
(Assignee)

Comment 9

20 years ago
Actually, I picked ISO-8859-1 out of a hat.  UTF-8 works equally well.  I was
just using that as an example.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 10

20 years ago
Verified invalid.
You need to log in before you can comment on or make changes to this bug.