Fix about:telemetry to work with the unified pings

RESOLVED FIXED in Firefox 39

Status

()

Toolkit
Telemetry
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: vladan, Assigned: vladan)

Tracking

unspecified
mozilla39
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
about:telemetry doesn't load because of an exception "TypeError: value is null"

  renderBody: function KeyValueTable_renderBody(aTable, aMeasurements) {
    for (let [key, value] of Iterator(aMeasurements)) {
      // use .valueOf() to unbox Number, String, etc. objects
====> if ((typeof value == "object") && (typeof value.valueOf() == "object")) {
        value = RenderObject(value);
      }

I think this exception occurs when handling the "System Information" section
(Assignee)

Comment 1

3 years ago
Created attachment 8574090 [details] [diff] [review]
aboutTelemetryNull.patch
Attachment #8574090 - Flags: review?(nfroyd)
(Assignee)

Updated

3 years ago
Attachment #8574090 - Flags: review?(nfroyd) → review?(dteller)
Comment on attachment 8574090 [details] [diff] [review]
aboutTelemetryNull.patch

Review of attachment 8574090 [details] [diff] [review]:
-----------------------------------------------------------------

This definitely makes sense.
Attachment #8574090 - Flags: review?(dteller) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/11282d8746ea
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/11282d8746ea
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla39

Updated

3 years ago
Duplicate of this bug: 1137545
You need to log in before you can comment on or make changes to this bug.