[Flame][Settings]The back button can't work at Enter FDN view.

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: eragonj)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master unaffected)

Details

Attachments

(4 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame v2.2][Settings] Keyboard disappeared after tapping back button for the first time, but there is no response when you keep tapping the back button at Enter FDN view and Enter PUK2 code view.
Found time:11:03
See attachment:video.MP4 and logcat_1103.txt

[2.Testing Steps]: 
Prerequisite: Insert a SIM card.
1. Launch Settings.
2. Tap Call Settings -> SIM 1 -> Fixed Dialing Numbers.
3. Enable Fixed Dialing Numbers and then tap back button at left top.
4. Input a wrong PIN2 and then tap back button at Enter PUK2 code view.

[3.Expected Result]: 
3&4. It will back to previous page.

[4.Actual Result]: 
3&4.  Keyboard disappeared after tapping back button for the first time, but there is no response when  you keep tapping the back button.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
Reporter

Comment 1

4 years ago
Posted file logcat_1103..txt
Reporter

Comment 2

4 years ago
Posted video video.MP4
Set 2.2? for breaking existing functionality.
blocking-b2g: --- → 2.2?

Comment 4

4 years ago
Triage: blocking.
Assignee: nobody → ejchen
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8574491 [details] [review]
[gaia] EragonJ:v2.2-bug-1139793 > mozilla-b2g:v2.2

Arthur, this is just a one-line fix for this problem. If I am guessing this problem rightly, this problem should be existed there when gaia-header is included within this page. And the reason why we don't have this problem in v3.0 is because we use dialogService to control the flow for all cases and this has been handled correctly inside dialogService.

Please help me check this PR when you have time, thanks Arthur :)
Attachment #8574491 - Flags: review?(arthur.chen)
Comment on attachment 8574491 [details] [review]
[gaia] EragonJ:v2.2-bug-1139793 > mozilla-b2g:v2.2

r=me, thanks!
Attachment #8574491 - Flags: review?(arthur.chen) → review+
Comment on attachment 8574491 [details] [review]
[gaia] EragonJ:v2.2-bug-1139793 > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: Users can't go back to previous page when trying to update FDN.
[Testing completed]: no test, only one HTML change
[Risk to taking this patch] (and alternatives if risky):l ow
[String changes made]: no
Attachment #8574491 - Flags: approval-gaia-v2.2?
Adding checkin-needed as this is a branch specific patch.
Keywords: checkin-needed
Attachment #8574491 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
http://docs.taskcluster.net/tools/task-graph-inspector/#1ts6hjw2TKi8EZ7JpX8yBw

The pull request failed to pass integration tests. It could not be landed, please try again.
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#tM5TmoZjRailc5YkNZlISQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Thanks Autolander.

v2.2: https://github.com/mozilla-b2g/gaia/commit/03adf96933e308e2b10fd39d458a0bae28e378e9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
Reporter

Comment 13

4 years ago
Posted video video.MP4
This issue has been verified succeffully on Flame 2.2, the back button can work normally.
See attachment:video.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150312002501
Gaia Revision          572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gaia Date              2015-03-12 01:29:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.040315
Firmware Date          Thu Mar 12 04:03:26 EDT 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.