[RTL][Dialer]The sequence of duration time, Phone number, and Call status icon remains the same as that in LTR.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: thills)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=3])

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Posted image screenshot.png
[1.Description]:
[RTL][Dialer]The sequence of duration time, Phone number, and Call status icon are not reversed, it remains the same as that in LTR.
See attachment:screenshot.png

[2.Testing Steps]: 
1. Set your phone language to Arabic and save some contacts.
2. Establish a call.
3. MT a call from another device.
4. Answer the call.

[3.Expected Result]: 
4. The sequence of duration time, Phone number, and Call status icon should be reversed.

[4.Actual Result]: 
4. The sequence of duration time, Phone number, and Call status icon still remains the same as that in LTR.

[5.Reproduction build]: 
Nexus 5:
Build ID               20150303002527
Gaia Revision          3d188c414e30acc392253d5389a42352fcfbc183
Gaia Date              2015-03-03 00:53:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c89aad487aa5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150303.040940
Firmware Date          Tue Mar  3 04:09:55 EST 2015
Bootloader             HHZ12d
Device Name            hammerhead

Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15510
(Reporter)

Comment 1

4 years ago
Please ignore the info of Nexus 5 in Description.
QA Whiteboard: [rtl-impact]
Tamara, this looks like the issue you were discussing with Stephany. I couldn't find a dupe for it. Do you have the bug number?
Flags: needinfo?(thills)
(Assignee)

Comment 3

4 years ago
Hi Johan,

This is a different issue.  Bug 1011066 was the one where we were discussing whether it should be mirrored in the lockscreen when there is an incoming call.  I believe this bug is valid as we should also mirror this for RTL.

Thanks,

-tamara
Flags: needinfo?(thills)
Triage - P2. Nominating since this is an inconsistency in RTL behavior
blocking-b2g: --- → 2.2?
Priority: -- → P2
triage: issue on new feature RTL
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → thills
Whiteboard: [planned-sprint c=3]
Target Milestone: --- → 2.2 S8 (20mar)
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/15510/
Flags: in-moztrap+

Updated

4 years ago
Status: NEW → ASSIGNED
Status: ASSIGNED → NEW
(Assignee)

Comment 7

4 years ago
Posted image conferencearrow.png
Hi Delphine,

Can you have a look at this and let me know if the arrow with the box around it should be pointing to the left and moved to the left side?  I just want to confirm before I ask for an arrow to be created pointing in that direction.

For context, this is the "Conference(2)" screen on the callscreen when a user has multiple parties in a conf and they can click the arrow to see that detail.

Thanks,

-tamara
Flags: needinfo?(lebedel.delphine)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Hey Tamara - to stay consistent with 2.2 RTL specs, I would say that the arrow should be on the left side and pointing like in your screenshot (>), with the text right aligned. 
This would be consistent with behavior described on 2.2 specs https://mozilla.app.box.com/s/bcm3s5i2v6js5uk0ws3tsywse8bgncgo p.13, image F, since we are going "deeper" in the phone here thanks to this arrow.
Flags: needinfo?(lebedel.delphine)
(Assignee)

Updated

4 years ago
Attachment #8575948 - Flags: review?(gsvelto)
Posted image Review screenshot (obsolete) —
The PR looks mostly good to me and I like how you reorganized some CSS rules to make more sense when read in sequence in the file. However I spotted a problem with the result which might or might not be an issue since there's no visual spec for this. It seems to me that all the elements are shifted to the left by 1.4rem too much. To explain this better I've attached two screenshots (LTR on the left, RTL on the right) on which I marked the issue. I would expect the spacing between the elements to be mirrored when going into RTL mode; instead with your patch applied everything looks shifted to the right with too little spacing between the left edge and the duration and too much between the right edge and the icon.
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

R-'ing this for now so that you can reset the flag when you've updated the PR.
Attachment #8575948 - Flags: review?(gsvelto) → review-
(Assignee)

Comment 12

4 years ago
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

Hi Gabriele,

I adjusted the spacing to mirror more closely the LTR.  Thanks for catching that.  Also I modified the following:

1. I noticed that there is very little space between the icon and the name in the LTR version.  I modified RTL to mirror this so there is less space in RTL between name and icon.

2. I fixed up the call ended scenario for RTL a little bit.  I noticed that when you end a multi-line call in RTL that the name and additionalContactInfo get truncated unnecessarily.

I did not squash it as it might be easier just to look at what I changed since last time.  If not, let me know and I'll squash.

Many thanks,

-tamara
Attachment #8575948 - Flags: review- → review?(gsvelto)
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

Thanks for keeping the patches split, it's easier to read this way. Everything looks fine except for the arrow in conference mode which appears shifted too close to the left border in RTL mode. I'll attach a snapshot that highlights the issue.
Attachment #8575948 - Flags: review?(gsvelto) → review-
Posted image Review screenshot
Attachment #8577889 - Attachment is obsolete: true
(Assignee)

Comment 15

4 years ago
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

Hi Gabriele,

I adjusted the padding on this and left it as a separate commit.

Thanks,

-tamara
Attachment #8575948 - Flags: review- → review?(gsvelto)
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

Now everything's looking fine. BTW during my testing I've noticed that there are still a fair amount of elements that aren't properly localized using l10n-ids so if you switch language with the callscreen open you can still see the string used when the element was created rather than the proper string for the newly selected locale. I'll file follow-ups for these issues unless I can find existing bugs covering them already.
Attachment #8575948 - Flags: review?(gsvelto) → review+
(Reporter)

Comment 18

4 years ago
Posted image v3.0_verify.png
This issue has been verified successfully on latest build of Flame 3.0 with same steps in comment 0. The sequence of duration time, Phone number, and Call status icon are reversed. They are shown as "duration time, Phone number, Call status icon" from left to right.
See attachment:v3.0_verify.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150325160204
Gaia Revision          508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gaia Date              2015-03-25 16:54:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.191758
Firmware Date          Wed Mar 25 19:18:07 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
(Assignee)

Comment 19

4 years ago
Comment on attachment 8575948 [details] [review]
[gaia] tamarahills:bugfix/1139801-rtl-layout-of-callscreen-multicall > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL feature
[User impact] if declined: Arabic users will see things backwards in the callscreen
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky):  Should be low since only css changes.
[String changes made]: no
Attachment #8575948 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8575948 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Reporter)

Comment 21

4 years ago
This issue has been verified successfully on latest build of Flame 2.2 with same steps in comment 0. The sequence of duration time, Phone number, and Call status icon are reversed. They are shown as "duration time, Phone number, Call status icon" from left to right.
Rate:0/3

Device: Flame 2.2 (pass)
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.