Closed Bug 1139922 Opened 7 years ago Closed 7 years ago

Reftest not properly symbolicating assertion stacks

Categories

(Testing :: Reftest, defect)

defect
Not set
major

Tracking

(firefox40 fixed)

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: ted, Assigned: ted)

References

Details

bug 1139604 had a log with a crashtest assertion whose stack frames didn't have symbols. reftest should be using fix_stack_using_bpsyms to symbolicate them:
https://dxr.mozilla.org/mozilla-central/source/layout/tools/reftest/runreftest.py#452

I don't know why this didn't work here. When I downloaded the symbols for that build and piped the log through my local copy of fix_stack_using_bpsyms it produced sensible output, so maybe something is mucked up inside the harness?
Fwiw, I've run into this on try a bunch of times in the last few weeks, and it's made debugging try failures a real PITA...
Severity: normal → major
Seems like the problem is that mozinfo.info.get('debug') isn't actually true in debug builds.
Assignee: nobody → ted
https://hg.mozilla.org/mozilla-central/rev/6441783352b4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.