Closed Bug 1139967 Opened 7 years ago Closed 5 years ago

toggling from reader view back to standard render view refreshes page

Categories

(Toolkit :: Reader Mode, defect, P3)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1184950

People

(Reporter: edwong, Unassigned)

References

Details

desc: usability issue, it's quite jarring to have to reload the whole page, even though I just had the page.  This is especially painful on a tablet or phone where you're paying for each byte.

1. load an page that can be parsed in reader view (an article)
2. click on the reader view icon in address bar
3. you're in reader view now, then tap the icon again to switch back to standard view mode

actual: the page is reloaded/refreshed

expected: page should just switch back without reload. Safari simply flips between reader and standard views.
Unfortunately, this is just how reader mode has always worked on Android, mainly due to the fact that you can enter reader view directly from your reading list, and in that case there's not actually an original page to restore.

To do what we suggest, we would need to create a separate frame for reader view, which would also allow us to do something like animate the reader view content over the original content (see bug 1126967).

I agree this transition is kinda janky right now, and we should do something to improve this, but I think it would be a challange to have a fix for this in the Firefox 38 timeline.
Component: Reading List → Reader Mode
Product: Firefox → Toolkit
Version: 37 Branch → Trunk
Priority: -- → P3
Fixed as part of bug 1184950 for back/fwd-cachable pages.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184950
You need to log in before you can comment on or make changes to this bug.