Closed Bug 1140017 Opened 5 years ago Closed 2 years ago

test_dialer_clear_miss_call_notification.py is timing out after receiving the missed call.

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Marty, Unassigned)

Details

Attachments

(2 files)

Attached file nonsmoke2.html
The test (test_dialer_clear_miss_call_notification.py) is failing consistently on the latest automated run, both locally, and on Jenkins. It appears that the device is timing out after receiving the missed call, before pulling down the notification tray.

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_clear_miss_call_notification.py", line 54, in test_dialer_clear_miss_call_notification
call_screen.wait_for_incoming_call()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py", line 94, in wait_for_incoming_call
call = self.marionette.find_element(*self._incoming_call_locator)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 1448, in find_element
response = self._send_message('findElement', 'value', **kwargs)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 670, in _send_message
self._handle_error(response)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 709, in _handle_error
raise errors.NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: .handled-call.incoming

Repro Rate: 20/20

I was unable to reproduce this issue manually after 10 attempts.

First Failing: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/66/testReport/junit/%28root%29/test_dialer_clear_miss_call_notification_py%20TestDialerClearMissCallNotification_test_dialer_clear_miss_call_notification/test_dialer_clear_miss_call_notification_py_TestDialerClearMissCallNotification_test_dialer_clear_miss_call_notification/history/

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	05 Mar 2015 01:32:30
Device firmware (incremental) 	eng.cltbld.20150305.043221
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	04 Mar 2015 09:42:47
Gaia revision 	eff3321ab4e6
Gecko build 	20150305010212
Gecko revision 	56492f7244a9
Gecko version 	39.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Attached file clearmisscall.html
Attaching the results from the local run of the case.
After running the automation case another 20 times on 2 different devices, we passed 100% of the time (20/20).  It is possible this is an intermittent issue with the Plivo service.
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
FWIW, Plivo didn't report any issue since Feb 10: https://status.plivo.com/past_month/
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.