Closed Bug 1140039 Opened 5 years ago Closed 5 years ago

test_sms_to_dialer.py is intermittently failing with a timeout.

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Marty, Unassigned)

References

()

Details

Attachments

(2 files)

The test (test_sms_to_dialer.py) is intermittently failing both locally and on Jenkins. The behavior seems somewhat different locally than in the Jenkins results.  I've attached my local results for comparison with the traceback from Jenkins seen below.

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_to_dialer.py", line 25, in test_dialer_from_message
self.data_layer.send_sms(self.environment.phone_numbers[0], _text_message_content)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 432, in send_sms
result = self.marionette.execute_async_script('return GaiaDataLayer.sendSMS(%s, %s)' % (number, message), special_powers=True)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 1420, in execute_async_script
debug_script=debug_script)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 670, in _send_message
self._handle_error(response)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 739, in _handle_error
raise errors.ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
ScriptTimeoutException: ScriptTimeoutException: timed out

Repro Rate: 7/20

I was unable to reproduce this issue manually after 10 attempts.

First failing:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/66/testReport/%28root%29/test_sms_to_dialer_py%20TestDialerFromMessage_test_dialer_from_message/test_sms_to_dialer_py_TestDialerFromMessage_test_dialer_from_message/history/

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	05 Mar 2015 01:32:30
Device firmware (incremental) 	eng.cltbld.20150305.043221
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	04 Mar 2015 09:42:47
Gaia revision 	eff3321ab4e6
Gecko build 	20150305010212
Gecko revision 	56492f7244a9
Gecko version 	39.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Attached file nonsmoke2.html
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
I don't get any failure, using:
Gaia-Rev        2fb09da0cb9cefad9c6e40f57533fafda6d12557
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6686aacf006f
Build-ID        20150310010227
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150204.192122
FW-Date         Wed Feb  4 19:21:34 EST 2015
Bootloader      L1TC100118D0

I tried this test 14 times in total.

Martin, are you still seeing this in today's build? Otherwise, please mark this bug worksforme.
Flags: needinfo?(mshuman)
We haven't seen this issue since the day we reported it. I just ran it 10 times locally to be sure, and it passed 100%. Closing as WorksForMe.
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage+][fxosqa-auto-backlog?] → [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.