Closed Bug 1140071 Opened 5 years ago Closed 2 years ago

mp3, no play but play when download it

Categories

(Core :: Audio/Video: Playback, defect)

36 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED INACTIVE

People

(Reporter: henryzurieta, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

In the address bar I set my browser ogg file and plays it.
"file:///mnt/inform/p/sitio/musica/Amigo.ogg"
then
"file:///mnt/inform/p/sitio/musica/Amigo.mp3"
but no plays


My computer:
-Version-
Kernel		: Linux 3.10.27avl2-pae (i686)
Compiled		: #5 SMP PREEMPT Sun Jan 19 21:18:51 EST 2014
C Library		: Unknown
Default C Compiler		: GNU C Compiler version 4.6.1 (Debian 4.6.1-15) 
Distribution		: Debian GNU/Linux 6.0.9
-Current Session-
Computer Name		: marx.proyectonavegar.info
User Name		: marx (Carlos Marx)
Home Directory		: /home/marx
Desktop Environment		: XFCE 4


-Computer-
Processor		: 4x Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz
Memory		: 2070MB (1475MB used)
-Display-
Resolution		: 1360x768 pixels
OpenGL Renderer		: Gallium 0.4 on NVA3
X11 Vendor		: The X.Org Foundation
-Multimedia-
Audio Adapter		: HDA-Intel - HDA Intel
Audio Adapter		: HDA-Intel - HDA NVidia
Audio Adapter		: Loopback - Loopback
-Input Devices-
 AT Translated Set 2 keyboard
 Power Button
 Power Button
 PC Speaker
 ImPS/2 Generic Wheel Mouse
 ACPI Virtual Keyboard Device
-Printers (CUPS)-
Adobe_PDF_7_0
EPSON_Artisan_720
EPSON_EPSON_Epson_Stylus_TX130_Series
EPSON_Epson_Stylus_TX130
Xerox_Phaser_3250-1
-SCSI Disks-
HL-DT-ST DVDRAM GH22NS40
ATA ST3250620AS
FLASH Drive SM_USB20




Actual results:

In the address bar I set my browser ogg file and plays it.
"file:///mnt/inform/p/sitio/musica/Amigo.ogg"

Then I did the same, but with the mp3 version:
"file:///mnt/inform/p/sitio/musica/Amigo.mp3"
 and the browser will not play. 
Then download the file with the context menu (save audio as ...), the mp3 file plays without any problems with any player


Expected results:

Plays the file:///mnt/inform/p/sitio/musica/Amigo.mp3
QA Whiteboard: [bugday-20150309]
Component: Untriaged → Video/Audio
Product: Firefox → Core
Potentially related SuMo thread: https://support.mozilla.org/questions/1052639 

Website's MP3s played in the native player in Firefox 35 but will not play in Firefox 36. A re-encoded version will play in Firefox 36 (sample link provided). The difference between the media is not obvious to the lay person.
Pardon me, but I have something to share. For some time now, I have landed on a web
page with a clip on it. Sometimes, the clip that is suppose to play does not play.
I used to think it was because the clip was no longer available. However, I have
several download helpers on my Firefox, and they became active on many of those
web pages. When I select to download the clip, it gets download without a problem.
Also, the plugin symbol on the address bar is displayed. So Firefox knows the clip
is there, and can download it. It just can't play it. Videos and audios.
Component: Audio/Video → Audio/Video: Playback
Mass closing because of inactivity.
Please feel free to re-open if still relevant.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.