[RTL][Clock] blue lines appear when scrolling an alarm with repeat option

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Clock
P3
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Description:
In Arabic, the user can scroll the alarm when the repear option is set other than "never". (In English, the scroll does not appear). When the user scrolls the alarm, there are thin, blinking, blue lines appear.

Repro Steps:
1) Update a Flame to 20150305010212.
2) Set the device language in Arabic under Settings > Language.
3) Open Clock app.
4) Add a new alarm, with the repeat option with any days.
5) On the main alarm screen, scroll the newly created alarm.


Actual:
Thin, blue lines appear.

Expected:
Either the scroll bar does not appear, or the user can scroll the alarm without any graphic issue.


Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: video clip
http://youtu.be/4wI_fNMapL4
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.2.

Result: The blue lines appear when the user scrolls an alarm with repeat option.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
Created attachment 8573477 [details]
GraphicIssue.png
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
This appears to be a graphics issue and may be a recent regression. I do see it on today's 2.2 build but I'm not able to reproduce on a device running master build 20150223103044.
Keywords: regressionwindow-wanted
Priority: -- → P3
(Reporter)

Updated

3 years ago
QA Contact: ychung
(Reporter)

Comment 4

3 years ago
I don't think this is a regression. I noticed this issue only reproduces with full flash, and does NOT reproduce when shallow flashed. With full flash, this issue occurs on an earlier 2.2 nightly build from last year:

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

How would you like us to proceed?
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Flags: needinfo?(doliver)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [rtl-impact]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [rtl-impact] → [rtl-impact][QAnalyst-Triage+]
(Reporter)

Comment 5

3 years ago
This issue also reproduces on Flame 2.1 with full flash, although RTL is not officially supported on this branch.

Result: The blue lines appear when the user scrolls an alarm with repeat option.

Environmental Variables:
Device: Flame 2.1 (KK, 319mb, full flash)
Build ID: 20150305161203
Gaia: ea97a87048a4c1e2a479bbea1d75e0a182b2c4c9
Gecko: 871071010b5b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Tracking Requested - why for this release]:

Thanks, I think we can leave this as is then. We'll track it in our team but it's not worth nominating for blocking.
tracking-b2g: --- → ?
Flags: needinfo?(doliver)
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]
Created attachment 8646185 [details]
Verify_1_pass.png
This issue cannot be reproduced on latested build of FlameKK2.2 and FlameKK 2.5,AriesKK 2.5
Rate:0/5
Device:FlameKK_V2.2
Build ID               20150810032504
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da29b5af4232
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150810.065425
Firmware Date          Mon Aug 10 06:54:37 EDT 2015
Base Image             v18D v4
Bootloader             L1TC000118D0

Device:FlameKK_V2.5
Build ID               20150810150206
Gaia Revision          9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gaia Date              2015-08-10 16:01:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8cba870a352c
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150810.183734
Firmware Date          Mon Aug 10 18:37:46 EDT 2015
Base Image             v18D v4
Bootloader             L1TC000118D0

Device: AriesKK_V2.5
Build ID               20150810003528
Gaia Revision          09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gaia Date              2015-08-09 17:11:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0e269a1f1beb
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.000017
Firmware Date          Mon Aug 10 00:00:24 UTC 2015
Bootloader             s1
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.