If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

3rd Party Applications Issue Form

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Custom Bug Entry Forms
--
enhancement
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: thomas elin, Assigned: dkl)

Tracking

Production

Details

(Reporter)

Description

3 years ago
We’d like a form created to channel bugs/issues filed against 3rd party Marketplace apps.
This is the structure that we’re thinking:

Product: Marketplace
Component: 3rd Party Applications (new category)
Component Description: Bugs relating to 3rd party applications listed within the Firefox Marketplace.
Auto populate with the following people: mellis@mozilla.com (Assigned) and telin@mozilla.com (cc)

* Summary
** Description: Please enter the name of the application in brackets and a short summary of the issue. (ex. [App Name] Fails to launch at startup
** Maps to Bugzilla field: Summary (required)
 
* Marketplace App URL
** Description: Please copy the App listing page URL from Marketplace
** Maps to Bugzilla field: URL (Required)

* Detailed description of the issue or enhancement request
** Description: Please enter a description of the issue with as much detail as possible.
** Maps to Bugzilla field: Comment 0 (Required field)

* Is this issue reproducible?
** Description: Please let us know if this issue is reproducible, steps to reproduction, and how often the issue presents itself. 
** Maps to Bugzilla field: Comment 0 (appended to above) Required field
 
* Device Information
** Description: Please let us know what device you were using when you experienced this issue. For FirefoxOS devices; please include the device make, model, and OS version at a minimum. RAM, Chipset, and Screen size is preferred if that information is available.
** Maps to Bugzilla field: Comment 0 (appended to above) Required field.

* Mozilla Reference Device
** Description: Have you tried to reproduce this issue on a Mozilla reference device? If yes, please post your results, which device you were using, and OS version.
** Maps to Bugzilla field: Comment 0 (appended to above) Required field

*Have additional materials?
** Description: Please attach any additional information that will help us understand and diagnose this issue. Screenshots, testing documents, etc.
** Maps to Bugzilla field: Attachment

Is it possible to have this form live by the end of this month?
Component: General → Custom Bug Entry Forms
(Assignee)

Updated

3 years ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Due Date: 2015-03-31
(Assignee)

Comment 1

3 years ago
I have put a test form for you feedback up on our devel instance of BMO. Please go here:

https://bugzilla-dev.allizom.org/form.third.party

Try to create bugs, etc. and let me know if you need additional changes.

dkl
Flags: needinfo?(telin)
(Reporter)

Comment 2

3 years ago
Looks good David. I only see one change so far but i'd like to have a few folks take a look as well. Will get back to you on Monday at the latest.

Thanks much!
(Reporter)

Comment 3

3 years ago
Can you add a parenthesis to the end of the summary description?

(ex. [App Name] Fails to launch at startup) <-----

Looks like I missed it in my original request.
(Reporter)

Comment 4

3 years ago
Filed a bug and everything worked great. 

One note, I noticed that the component description reads '3rd Party Applications'. Can we adjust that to 'Bugs relating to 3rd party applications listed within the Firefox Marketplace.'

Other than that we are good to go.

Thanks Again
Flags: needinfo?(telin)
(Reporter)

Comment 5

3 years ago
One more bit of feedback that just came in...

Please adjust device information description to the text below.

* Device Information
** Description: Please let us know what device you were using when you experienced this issue. For FirefoxOS devices; please include the device make, model, and OS version at a minimum. RAM, Chipset, Screen size, and buildID is preferred if that information is available. (You can find BuildID by using this nav path on your FirefoxOS device; Settings—>Device info—>More info)
** Maps to Bugzilla field: Comment 0 (appended to above) Required field.
(Assignee)

Comment 6

3 years ago
(In reply to thomas elin from comment #4)
> One note, I noticed that the component description reads '3rd Party
> Applications'. Can we adjust that to 'Bugs relating to 3rd party
> applications listed within the Firefox Marketplace.'

I will update the description on the production database.

(In reply to thomas elin from comment #5)
> One more bit of feedback that just came in...
> 
> Please adjust device information description to the text below.
> 
> * Device Information
> ** Description: Please let us know what device you were using when you
> experienced this issue. For FirefoxOS devices; please include the device
> make, model, and OS version at a minimum. RAM, Chipset, Screen size, and
> buildID is preferred if that information is available. (You can find BuildID
> by using this nav path on your FirefoxOS device; Settings—>Device info—>More
> info)
> ** Maps to Bugzilla field: Comment 0 (appended to above) Required field.

Done

Will be in the next update for production.

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   c25b318..8058b5d  master -> master

dkl
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
now live at https://bugzilla.mozilla.org/form.third.party
(Reporter)

Comment 8

3 years ago
The form is functioning properly but I don't see the component '3rd Party Applications' under the Marketplace product. I was able to see it before the change request in comment 5.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

3 years ago
Oops. I mistakenly added it to the 'Marketing' product and not the 'Marketplace' product. Fixed now :)

dkl
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

2 years ago
Hello Folks

I just tried using the form above and received an error "There is no version named 'unspecified' in the 'Marketplace' product."

Not sure if something has changed recently. Partners are unable to submit bugs while this error exists.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

2 years ago
(In reply to thomas elin from comment #10)
> Hello Folks
> 
> I just tried using the form above and received an error "There is no version
> named 'unspecified' in the 'Marketplace' product."
> 
> Not sure if something has changed recently. Partners are unable to submit
> bugs while this error exists.

Not sure where the version went but added it back.

dkl
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.