Closed Bug 11403 Opened 21 years ago Closed 21 years ago

[PP] Opening and closing the Abook seems to corrupt the New Card dialog

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3, major)

PowerPC
Mac System 8.5

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: esther, Assigned: chuang)

Details

Using 19990806 build on mac ppc, if you open and close the Address Book 3 times
in one Messenger session, the New Card dialog becomes corrupt.

1. Launch Messenger
2. Select Address Book from the Tasks menu list
3. Select the Personal Address Book
4. Select New Card then close using the Close button in the title bar
5. Close the Address Book
Repeat steps 2,3,4  two more times on the 3rd time the dialog in the box is
layered over the text boxes and everything is bunched up to to top 1/2.
Closing the dialog then opening a New Card again results in the dialog being the
size of the close button and is located in the upper left hand corner of the
screen.
QA Contact: lchiang → esther
Status: NEW → ASSIGNED
Target Milestone: M10
Assignee: hangas → chuang
Status: ASSIGNED → NEW
Reassigning to Candice.  This looks like a backend problem.  Esther said she
tried to make Seamonkey crash by opending and closing other windows but it did
not.  Because of this, I am thinking we should start with the address book
backend.
Esther,

Did you just open and close the dialog without typing any text?  There's really
no address book backend code involved with opening and closing the dilaog unless
you close it with the OK button.

Please try on other dilaogs (maybe preference, account wizard_ to see if you
have the same problem.  The problem seems to be a windwow size, position layout
problem to me.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Using mac build 19990820M9 this is not happening anymore, non-reproducible.
Also note there is no close button in the title bar anymore, so to close the
card you have only 2 choices, OK and Cancel.  I remember talking to Paul about
the close button and it was believed to be a bug that the mac had it.   So it
may have been part of the problem, but it's gone now.  Resolving this as
worksforme since no fix has been made and it's not reproducible.
I just verified this too.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.