Closed Bug 1140413 Opened 5 years ago Closed 4 years ago

Intermittent subsuper-fallback.html | image comparison (==), max difference: 255, number of differing pixels: 100

Categories

(Core :: Graphics: Text, defect)

x86
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox46 --- fixed
firefox47 --- fixed
firefox48 --- fixed

People

(Reporter: cbook, Assigned: jfkthame)

References

()

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted])

Android 4.0 armv7 API 11+ mozilla-inbound debug test plain-reftest-4

https://treeherder.mozilla.org/logviewer.html#?job_id=7292458&repo=mozilla-inbound

06:30:37 INFO - REFTEST TEST-UNEXPECTED-FAIL | http://10.26.133.17:30528/tests/layout/reftests/font-features/subsuper-fallback.html | image comparison (==), max difference: 255, number of differing pixels: 100
Duplicate of this bug: 1140426
Any ideas what might have started this around the 6th?
Component: Layout → Graphics: Text
Flags: needinfo?(jfkthame)
Flags: needinfo?(jdaggett)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #48)
> Any ideas what might have started this around the 6th?

Not offhand, sorry.

John, the screenshots here make it look as though synthetic sub/superscript glyphs are not being reduced in size at all, AFAICT. Is something broken?
Flags: needinfo?(jfkthame)
(In reply to Jonathan Kew (:jfkthame) from comment #53)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #48)
> > Any ideas what might have started this around the 6th?
> 
> Not offhand, sorry.
> 
> John, the screenshots here make it look as though synthetic sub/superscript
> glyphs are not being reduced in size at all, AFAICT. Is something broken?

That's bug 1141676, for which I have just posted a patch. It's not clear to me whether that'll make any significant difference to the reliability of this test, though.
Whiteboard: [gfx-noted]
I suspect this may have begun with bug 935862, which landed on inbound on 2015-03-06. :jtd, can you check on this?
(In reply to Jonathan Kew (:jfkthame) from comment #72)
> I suspect this may have begun with bug 935862, which landed on inbound on
> 2015-03-06. :jtd, can you check on this?

Argh, yes. I'm confused why I didn't pick up on that in tryserver runs but whatever. I think the fix for bug 1141676 should fix this. It's also related to bug 1139269.
Depends on: 1141676
Flags: needinfo?(jdaggett)
(In reply to John Daggett (:jtd) from comment #97)
> (In reply to Jonathan Kew (:jfkthame) from comment #72)
> > I suspect this may have begun with bug 935862, which landed on inbound on
> > 2015-03-06. :jtd, can you check on this?
> 
> Argh, yes. I'm confused why I didn't pick up on that in tryserver runs but
> whatever. I think the fix for bug 1141676 should fix this. It's also related
> to bug 1139269.

As predicted, it looks like the fix for bug 1141676 fixed the test failures originally reported here, typically on b2g, with differing pixels: 100. 

But since 2015-04-28, a new failure has been reported here, on Android 4.3, with differing pixels: 8. Is that bug 1139269? Is it just me, or does the test image look more correct (unclipped) than the reference image?
Flags: needinfo?(jdaggett)
(In reply to Geoff Brown [:gbrown] from comment #138)
> (In reply to John Daggett (:jtd) from comment #97)
> > (In reply to Jonathan Kew (:jfkthame) from comment #72)
> > > I suspect this may have begun with bug 935862, which landed on inbound on
> > > 2015-03-06. :jtd, can you check on this?
> > 
> > Argh, yes. I'm confused why I didn't pick up on that in tryserver runs but
> > whatever. I think the fix for bug 1141676 should fix this. It's also related
> > to bug 1139269.
> 
> As predicted, it looks like the fix for bug 1141676 fixed the test failures
> originally reported here, typically on b2g, with differing pixels: 100. 
> 
> But since 2015-04-28, a new failure has been reported here, on Android 4.3,
> with differing pixels: 8. Is that bug 1139269? Is it just me, or does the
> test image look more correct (unclipped) than the reference image?

Yes, this is basically bug 1139269. Why it's not more consistent is puzzling. I added a comment on bug 1139269.
Flags: needinfo?(jdaggett)
Assignee: nobody → jmuizelaar
Assignee: jmuizelaar → nobody
This bug and bug 1139269 aren't going anywhere and it's the top reftest failure at the moment. Can we fuzz this on Android to since the failures at least? Otherwise, maybe we can try reproducing and catching it in rr?
Flags: needinfo?(jfkthame)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #271)
> This bug and bug 1139269 aren't going anywhere and it's the top reftest
> failure at the moment. Can we fuzz this on Android to since the failures at
> least?

I notice it's already marked as random-if(cocoaWidget). I think we should just add ||Android to that for now. This is a genuine failure happening intermittently, not a test-pass that has a slight rendering difference, so it's more accurate to mark it as random than fuzzy.

> Otherwise, maybe we can try reproducing and catching it in rr?

AFAICS, we're not running into this on Linux, so I'm not sure rr is an option.
Flags: needinfo?(jfkthame)
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca6be40a72bad25dd46827df3642f41dfab63744
Bug 1140413 - Mark subsuper-fallback.html test as random on Android (as well) due to bug 1139269. (manifest annotation, no review)
Others have had luck reproducing failures in rr-chaos that had previously only occurred on other platforms (funny enough, Android and OSX are the ones that come specifically to mind), because the failures weren't really so much platform-specific but environment-specific. That's why I thought it might be worth trying.
You're right, that's possible.

It looks like bug 1139269 already has a (non-intermittent?) testcase, so that is probably the best place to start here (when someone has cycles to spend...); until that bug is resolved, we may as well just paper over this.
https://hg.mozilla.org/mozilla-central/rev/ca6be40a72ba
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.