Closed Bug 1140473 Opened 6 years ago Closed 6 years ago

44.1% MacOS 10.8 cart/tpaint/tsvgx/tp5o_scroll/tscrollx regression on Mozilla-Inbound (v.39) on March 03, 2015 from push da60b4e6c98b

Categories

(Core :: Graphics: Layers, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1139033

People

(Reporter: vaibhav1994, Unassigned)

References

Details

Talos has detected a Firefox performance regression from your commit da60b4e6c98b.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=da60b4e6c98b&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see: https://wiki.mozilla.org/Buildbot/Talos/Tests#tscroll.2C_tscrollx

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p macosx64 -u none -t svgr  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a tscrollx

Making a decision:
As the patch author we need your feedback to help us handle this regression.

Our wiki page oulines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Blocks: 1138995
bug 1139033 was filed and fixed already related to this regression.
:kats, can you comment on this- I wonder if the additional regressions showed up later and we fixed svg and not cart/tpain/*scroll* ?
Flags: needinfo?(bugmail.mozilla)
(In reply to Vaibhav (:vaibhav1994) from comment #0)
> This is a list of all known regressions and improvements related to your bug:
> http://alertmanager.allizom.org:8080/alerts.html?rev=da60b4e6c98b&showAll=1

All the OS X 10.6 regressions listed on this page were fixed by bug 1139033, and I expect the OS X 10.8 ones will be as well, once the data gets generated. If you look at the graphs you'll see that all the 10.8 data is a few days old and hasn't get caught up to March 5, which is when bug 1139033 landed. If these regressions persist after that I can look into it.
Flags: needinfo?(bugmail.mozilla)
ok, this is fun- osx 10.8 is now shut off and replaced by osx 10.10, so lets just assume all the 10.8 regressions are fixed :)
both osx 10.6 regressions have been fixed- should we close this bug out?
I think so.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139033
You need to log in before you can comment on or make changes to this bug.