Closed Bug 1140721 Opened 5 years ago Closed 4 years ago

Support for -remote from command line removed

Categories

(Core Graveyard :: X-remote, defect)

36 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dsugar, Unassigned)

References

Details

(Whiteboard: [wontfix?])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 2015022000

Steps to reproduce:

It seems the latest Firefox has depreciated the ability to send js commands to it from the command line, thereby making it rather useless to me.  I typically had used multiple profiles with firefox when doing work for a client that required this, so that I could keep my clients bookmarks, passwords, etc, separate from each other.  The following used to work fine for every version of firefox since mozilla seamonkey, maybe even in Netscape, but no longer works in firefox as of 36.0, at least on GNU/Linux:

firefox -P clientX -remote ""openURL($@,new-tab)"


Actual results:

Opens a new instance of firefox on the default profile and pointing to the default home page set for that profile.


Expected results:

Always before has opened the passed url under the instance running on the selected profiile.
Slight typo when I was posting this:   firefox -P secure -remote "openURL($@,new-tab)"

also, similarly, I used to use:

firefox -P secure -remote "ping()" 2>/dev/null >/dev/nul

to test if a given profile was already running, or if not, to start it.  This too is broken.  It seems everything to do with passing js commands is broken in 36...
-remote support was just removed, then restored.
Blocks: 1080319
QA Whiteboard: [bugday-20150309]
It works on 36.0.1, 37 and 38, but is planned to be removed in 39. See bug 1080319.
Component: Untriaged → X-remote
Product: Firefox → Core
Summary: Support for js from command line broken → Support for -remote from command line removed
Whiteboard: [wontfix?]
This was removed by design as seen in bug 1080319.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.