cnet.com serves desktop version

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: bug.zilla, Assigned: karlcow)

Tracking

Firefox 39
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff] [contactready] [country-us], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
cnet.com serves desktop version.
Works in Opera.
Galaxy S4 (4.4.4), 39.0a1
(Reporter)

Updated

3 years ago
Component: General → General
Product: Firefox → Firefox for Android
Version: unspecified → Firefox 39

Updated

3 years ago
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism

Updated

3 years ago
See Also: → bug 784450
(Assignee)

Comment 1

3 years ago
Created attachment 8574456 [details]
cnet-mobile.png

Hmm I still see a mobile site.
(Assignee)

Comment 2

3 years ago
What is the full UA string of your device?
You can see it at http://www.whatsmyua.info/
Flags: needinfo?(bug.zilla)
(Assignee)

Updated

3 years ago
Assignee: nobody → kdubost
(Reporter)

Comment 3

3 years ago
According to ua-parser:
ua
rawUa: Mozilla/5.0 (Android; Mobile; rv:39.0) Gecko/39.0
Firefox/39.0
string: Firefox Mobile 39.0
family: Firefox Mobile
major: 39
minor:
patch:
device: Other
os
string: Android
family: Android
major:
minor:
patch:
According to ua-parser-js:
ua
ua: Mozilla/5.0 (Android; Mobile; rv:39.0) Gecko/39.0
Firefox/39.0
browser
name: Firefox
version: 39.0
major: 39
engine
name: Gecko
version: 39.0
os
name: Android
version: undefined
device
model: undefined
vendor: undefined
type: mobile
cpu
architecture: undefined
According to platform.js:
ua
name: Firefox Mobile
version: 39.0
layout: Gecko
os
os: Android
device
product:
manufacturer:
description: Firefox Mobile 39.0 on Android
API
GET /api/v1?ua=<ua-string>&version=<ua-parser-
version>
Parameters:
ua-string: Be sure to url-encode it. Defaults to your request\'s
user agent string.
ua-parser-version: Coming soon. Defaults to "latest".
Flags: needinfo?(bug.zilla)
39 is trunk, are they parsing on version?
They run some server-side, version-sensitive browser sniffing. 


------------------------------------------------------------------
GET http://www.cnet.com/ HTTP/1.1
Host: www.cnet.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: no,en-US;q=0.8,en;q=0.5,fr;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive


HTTP/1.1 200 OK
Server: nginx
Content-Type: text/html; charset=UTF-8
Cache-Control: max-age=300, private
X-Tx-Id: cb346358-66dd-41ac-9397-db567fef40f9
Expires: Fri, 20 Mar 2015 20:49:31 GMT
Access-Control-Allow-Origin: http://www.cnet.com
Content-Length: 71024
Accept-Ranges: bytes
Vary: Accept-Encoding
Date: Fri, 20 Mar 2015 20:48:52 GMT
Connection: keep-alive
Set-Cookie: fly_geo={&quot;countryCode&quot;: &quot;no&quot;}; expires=Fri, 27-Mar-2015 20:48:52 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_default_edition=us; expires=Fri, 27-Mar-2015 20:48:52 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_device=mobile; expires=Fri, 27-Mar-2015 20:48:52 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_zip=; expires=Fri, 27-Mar-2015 20:48:52 GMT; path=/; domain=.cnet.com



------------------------------------------------------------------
GET http://www.cnet.com/ HTTP/1.1
Host: www.cnet.com
User-Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: no,en-US;q=0.8,en;q=0.5,fr;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive


HTTP/1.1 200 OK
Server: nginx
Content-Type: text/html; charset=UTF-8
Cache-Control: max-age=300, private
X-Tx-Id: 637b9a6a-e6da-4e5b-a94f-3c90ae8716e5
Expires: Fri, 20 Mar 2015 20:49:32 GMT
Access-Control-Allow-Origin: http://www.cnet.com
Content-Length: 292998
Accept-Ranges: bytes
Vary: Accept-Encoding
Date: Fri, 20 Mar 2015 20:47:14 GMT
Connection: keep-alive
Set-Cookie: fly_geo={&quot;countryCode&quot;: &quot;no&quot;}; expires=Fri, 27-Mar-2015 20:47:14 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_default_edition=us; expires=Fri, 27-Mar-2015 20:47:14 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_device=desktop; expires=Fri, 27-Mar-2015 20:47:14 GMT; path=/; domain=.cnet.com
Set-Cookie: fly_zip=; expires=Fri, 27-Mar-2015 20:47:14 GMT; path=/; domain=.cnet.com
------------------------------------------------------------------
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [serversniff] [contactready] [country-us]
(In case it isn't obvious: the evidence is the Content-Length header. They send very different amounts of content to Firefox/39.0 and Firefox/18.0)
(Assignee)

Comment 7

3 years ago
The bug is Firefox Android 39 according to Comment #3
Just tested on firefox Android 39 

15:39:00.622 navigator.userAgent
15:39:00.282 "Mozilla/5.0 (Android; Mobile; rv:39.0) Gecko/39.0 Firefox/39.0"

And I receive the mobile site.


For Firefox OS, 
* 37 is receiving the desktop site.
* 18.1, 18.0 are receiving the desktop site.


So I maintain Cnet on Android has no issue for my tests at least.
Ops, sorry. Didn't notice this was Android.

bug.zilla: still seeing this? Have you accidentally enabled "Desktop mode" or similar?
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 9

3 years ago
Hi, it seems to be working now.
I haven;t changed anything in the meantime.

Thanks for your help.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bug.zilla)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.