bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Small desktop blocks appear when clicking on the UI




3 years ago
2 years ago


(Reporter: Marty, Unassigned)



36 Branch
Windows 7

Firefox Tracking Flags

(firefox36 affected, firefox-esr31 unaffected)




3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150307032730

Steps to reproduce:

Click on any toolbar where directly underneath are desktop icons 

Actual results:

Randomly but often small patches of the desktop appear where there is a click of the UI. It does not happen however if there are no desktop icons directly underneath where you are clicking.

It occurs only on Windows 7 (not XP) in Classic view (not tested in Aero) whether the following are on or off:

Hardware acceleration

It is not a problem in 31ESR or other applications such as IE and began sometime around 34 nightly. Tested also with a new profile and with no addons or themes. The video card is an ATI 4000 series with the latest 12.7 legacy drivers.   

To reproduce easily click two tabs back and forth.

A screenshot:

Comment 1

3 years ago
Can anyone take a look at this? The latest nightlies are impossible to use for some of us on Windows 7 with this bug.
status-firefox36: --- → affected
status-firefox-esr31: --- → unaffected
Component: Untriaged → Graphics
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core
Version: Firefox 38 → 36 Branch
Update your GPU drivers to the latest one (probably 13.9, as I can see on AMD site) and redo the issue STR. Next please post here your Graphic section from about:support if the bug will still be happening.
Flags: needinfo?(marty6001)

Comment 3

3 years ago
The latest legacy drivers for Windows 7 are 13.9 and they were updated several weeks ago as I too thought that might help but it didn't, it's still a problem.

This is the graphics info:

Adapter Description	ATI Radeon HD 4670
Adapter Description (GPU #2)	AMD FireStream 9170
Adapter Drivers	ati2dvag
Adapter Drivers (GPU #2)	aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Adapter RAM	Unknown
Adapter RAM (GPU #2)	1024
Asynchronous Pan/Zoom	none
ClearType Parameters	Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x9495
Device ID (GPU #2)	0x9498
DirectWrite Enabled	false (6.1.7601.18245)
Driver Date	4-29-2013
Driver Date (GPU #2)	4-29-2013
Driver Version	8.970.100.1100
Driver Version (GPU #2)	8.970.100.1100
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic
Subsys ID	00281002
Subsys ID (GPU #2)	29331682
Supports Hardware H264 Decoding	false
Vendor ID	0x1002
Vendor ID (GPU #2)	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Radeon HD 4670 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(marty6001)
Marty, can you find a regression window for this using mozregression (http://mozilla.github.io/mozregression/)
Flags: needinfo?(marty6001)

Comment 5

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> Marty, can you find a regression window for this using mozregression
> (http://mozilla.github.io/mozregression/)

The bug was introduced somewhere around early 34 nightly or perhaps late 33. I'll have to go back and find the exact build, which will take time.
Flags: needinfo?(marty6001)
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
Flags: needinfo?(marty6001)
Keywords: regressionwindow-wanted

Comment 6

2 years ago
With recent nightly builds this problem is no longer noticeable. As far as I can tell the bug appears resolved.
(In reply to Marty from comment #6)
> With recent nightly builds this problem is no longer noticeable. As far as I
> can tell the bug appears resolved.

Thanks, feel free to reopen this bug report if the issue returns.
You need to log in before you can comment on or make changes to this bug.