Closed Bug 1140903 Opened 6 years ago Closed 6 years ago

layers.async-pan-zoom.enabled broken on 8th March '15 nightly

Categories

(Core :: Panning and Zooming, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 1139220

People

(Reporter: tenisthenewnine, Assigned: dvander)

Details

Hey guys,

1. Install 7th March 2015 nightly, either 32bit or 64bit.
2. Enable layers.async-pan-zoom.enabled
3. Browse the web, I use reddit homepage as example
4. Update to the 8th March nightly. Now try to scroll reddit's fron page. It's scrolling one or two lines per 3 mouse wheel rolls!
5. Disable the preference, scrolling comes back to normal.

Looking through the changelog, the only bug that stands out is this one:

https://bugzilla.mozilla.org/show_bug.cgi?id=1126090
Blocks: 1086162
Status: UNCONFIRMED → NEW
Component: Untriaged → Panning and Zooming
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
Assignee: nobody → dvander
Blocks: 1126090
No longer blocks: 1086162
It's not broken, it just never worked right to begin with since APZ was ignoring scroll listeners. Now that it is, you're seeing bug 1139220. I'll try to fix that ASAP.
No longer blocks: 1126090
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139220
You need to log in before you can comment on or make changes to this bug.