[Rocketbar][Search engine] The default search engine is set to DuckDuckGo instead of Yahoo

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: daleharvey)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(4 attachments)

Description:
When opening the rocketbar, or browser and starting a search, the search provider is shown below the search. The default search provider is DuckDuckGo, instead of Yahoo.


Repro Steps:
1) Update a Flame to 20150309010232
2) Tap on the rocketbar
3) Begin typing
4) Observe search engine that is selected


Actual:
Default search engine is DuckDuckGo


Expected:
Default search engine is Yahoo

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150309010232
Gaia: fea83511df9ccba64259346bc02ebf2c417a12c2
Gecko: eab4a81e4457
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 15/15
See attached: Logcat, Screenshot
This issue DOES occur on Flame 2.2

Default search engine is DuckDuckGo

Environmental Variables:
Device: Flame 2.2
Build ID: 20150309002506
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 91b7aa6a3243
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


This search engine feature does not exist on 2.1
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Assignee

Updated

4 years ago
Assignee: nobody → dale
blocking-b2g: --- → 2.2+
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Assignee

Updated

4 years ago
Attachment #8575663 - Flags: review?(kgrandon)
Comment on attachment 8575663 [details] [review]
[gaia] daleharvey:1141315 > mozilla-b2g:master

This looks good, but I am concerned about the Gip test failure. Could you take a look and re-flag me when addressed?
Flags: needinfo?(dale)
Attachment #8575663 - Flags: review?(kgrandon) → feedback+
Assignee

Comment 5

4 years ago
Comment on attachment 8575663 [details] [review]
[gaia] daleharvey:1141315 > mozilla-b2g:master

Asked about this over IRC

The failing tests is brittle (depends on google layout), breaks tree visibility rules (depends on the network) and the functionality it tests is well covered by Gij tests (https://github.com/mozilla-b2g/gaia/blob/master/apps/search/test/marionette/search_rocketbar_test.js being one)

So seems best to delete instead of rewrite, Gij doesnt currently run on device but that is being worked on.
Flags: needinfo?(dale)
Attachment #8575663 - Flags: review?(martijn.martijn)
Attachment #8575663 - Flags: review?(kgrandon)
(In reply to Dale Harvey (:daleharvey) from comment #5)
> So seems best to delete instead of rewrite, Gij doesnt currently run on
> device but that is being worked on.

Yes, but that's not the case, atm, afaik, so that means this part won't be covered anymore on device.
Attachment #8575663 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8575663 [details] [review]
[gaia] daleharvey:1141315 > mozilla-b2g:master

Sounds good to me then, thanks!
Attachment #8575663 - Flags: review?(kgrandon) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: 1128841
Target Milestone: --- → 2.2 S8 (20mar)
Could you please uplift to 2.2? Thanks.
Assignee

Comment 10

4 years ago
Comment on attachment 8575663 [details] [review]
[gaia] daleharvey:1141315 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New Feature Dev
[User impact] if declined: Little
[Testing completed]: Manual verification, configuration change
[Risk to taking this patch] (and alternatives if risky): Little risk, config change
[String changes made]:
Attachment #8575663 - Flags: approval-gaia-v2.2?
Keywords: verifyme
Attachment #8575663 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted image screenshot
This problem is verified pass on latest build of Flame 3.0.
See attachment: Verify_screenshot.png
Rate:0/5

Flame 3.0 build:
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
Verify 2.2 on flame with below build.

Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.