[RTL][Dialer]The call icon and telephone number shift and overlap with the SIM info in "Call information" page

RESOLVED DUPLICATE of bug 1139179

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED DUPLICATE of bug 1139179
3 years ago
3 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[RTL][Flame][v2.2&v3.0][Dialer]When user inserts two SIM cards , and go to "Call information" page from Call log, you can see the call icon and telephone number shift and overlap with the SIM info.
See picture : "2015-03-10-15-03-55.png"

[2.Testing Steps]: 
Premise: There are some Calll log
1. Set your phone language to Arabic and insert two SIM cards in device. 
2. Launch Dialer.
3. Switch to "Call log page"
4. Long press one of the call log.
5. Press "Call information" item.

[3.Expected Result]: 
5. The call icon and telephone number shouldn't shift and overlap with the SIM info.

[4.Actual Result]: 
5. The call icon and telephone number shift and overlap with the SIM info.

[5.Reproduction build]: 
Flame 2.2:
Build ID               20150309002506
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/91b7aa6a3243
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.040114
Firmware Date          Mon Mar  9 04:01:25 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:
Build ID               20150309160227
Gaia Revision          4ef1fa9b2870499fc9c77cac4a15f62e12a3ad2c
Gaia Date              2015-03-09 02:53:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23f1f0369df5
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.192301
Firmware Date          Mon Mar  9 19:23:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
(Reporter)

Comment 1

3 years ago
Created attachment 8575180 [details]
Bug picture: 2015-03-10-15-03-55.png
blocking-b2g: --- → 2.2?
Priority: -- → P2
triage: major issue on new feature
blocking-b2g: 2.2? → 2.2+
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Updated

3 years ago
See Also: → bug 1139179
The code affecting this bug is shared between Contacts and Dialer. This bug should be verified once bug 1139179 lands.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1139179

Comment 4

3 years ago
Created attachment 8601979 [details]
verify_pass.png

Since bug 1139179 had been landed, this problem has been verified as pass on latest build of Flame 2.2/3.0 by the STRs in comment 0.
Result: The call icon and telephone number are not overlapped with the SIM info.
See attachment:verify_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150505162504
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.201112
Firmware Date          Tue May  5 20:11:25 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150505160203
Gaia Revision          42dc5f02a9df006b129824cd9bffa93cab937ab2
Gaia Date              2015-05-05 11:06:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5907a8eca521
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.194217
Firmware Date          Tue May  5 19:42:28 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
status-b2g-v2.2: affected → verified
status-b2g-master: affected → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.