Mouse scroll wheel doesn't work near bottom of any page

RESOLVED WONTFIX

Status

()

Core
Event Handling
P2
major
RESOLVED WONTFIX
17 years ago
15 years ago

People

(Reporter: Waldemar Horwat, Assigned: Brian Ryner (not reading))

Tracking

Trunk
mozilla1.2alpha
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The mouse scroll wheel doesn't work if the mouse hovers near the bottom of any
HTML page displayed in a browser window.  This bug is independent of the myriad
other focus and form element scroll wheel bugs -- it occurs even on pages with
no form controls and which have been properly focused.

Moving the mouse above the bottom 50 pixels or so in the window reactivates the
scroll wheel; if the mouse moves back near the bottom of the window, the scroll
wheel again doesn't work.

Comment 1

17 years ago
Reporter, 
A url or a testcase would be helpful in reproducing this bug. Thanks!
(Reporter)

Comment 2

17 years ago
I wrote "any page".  The one you're looking at now is as good a test case as
any.  www.netscape.com and www.mozilla.org are two other fine test cases.
(Reporter)

Comment 3

17 years ago
Btw, I'm using the classic skin under MacOS 9.2.1, if that matters.
(Reporter)

Comment 4

17 years ago
The problem seems to be that although Navigator displays the toolbars at the top
of the window, it seems to think that they are at the bottom for the purposes of
determining valid mouse positions for using the scroll wheel to scroll the
window.  Using the mouse wheel to scroll the window works when the mouse is over
the toolbars (although maybe it shouldn't) and doesn't work (and should) when
the mouse is over the bottom n pixels of the window, where n is the height of
the toolbars.  Collapsing the toolbars decreases the size of the dead area at
the bottom of the window.
(Reporter)

Comment 5

17 years ago
Nominating for nsbeta1.  Basic usability bug.
Keywords: nsbeta1

Comment 6

17 years ago
*** Bug 117265 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
OS: Mac System 9.x → All
(Reporter)

Updated

17 years ago
Severity: normal → major
Priority: -- → P2

Comment 7

17 years ago
-> bryner, assuming this is not mac specific
Assignee: joki → bryner
(Reporter)

Comment 8

17 years ago
The symptoms of this bug have changed a bit recently.  Now the mouse wheel
doesn't work near the bottom of any page (as before), but once it has been used
successfully higher up on the page, it then begins to work near the bottom of
the page as well.  Weird.
Keywords: mozilla0.9.9, nsdogfood
(Reporter)

Comment 9

17 years ago
To re-trigger the bug, resize the window.  The scroll wheel won't work near the
bottom of the page until it has been used successfully in the middle of the window.

Comment 10

17 years ago
Seems to work ok on Mac OS X but we handle mousewheel scrolling differently
between X and 9.x.  
OS: All → Mac System 9.x

Comment 11

17 years ago
nsbeta1- per ADT triage team, ->1.2
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
This bug should be close 9.X is no more supported.
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
mac classic is no longer supported by Mozilla. Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.