Mulet nightly builds have incorrect automation mozconfigs

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: mshal, Assigned: mshal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

4 years ago
In bug 1132123 we moved mulet builds over to mozharness. The mulet mozconfigs are based on the browser mozconfigs, which set MOZ_AUTOMATION_UPLOAD_SYMBOLS=1 and MOZ_AUTOMATION_UPDATE_PACKAGING=1 when IS_NIGHTLY=yes. However, we don't want to do uploadsymbols and update-packaging for mulet, and the nightly builds break when it tries to do so.

We'll need to update the mulet mozconfigs to force these to zero, and the browser mozconfigs to default to 1 if not set.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Duplicate of this bug: 1141396
Assignee

Comment 6

4 years ago
We don't want to do balrog updates for mulet builds, so delete the 'update' action. I also got rid of the other commented-out actions.
Attachment #8575442 - Flags: review?(jlund)
Assignee

Comment 7

4 years ago
Posted patch mulet-nightlySplinter Review
mozconfig updates to disable uploadsymbols and update-packaging for mulet builds.
Attachment #8575444 - Flags: review?(bhearsum)
Attachment #8575444 - Flags: review?(bhearsum) → review+
Assignee

Comment 9

4 years ago
leave-open until mozharness is updated
Keywords: leave-open
Is there something else that needs to be set still? That did get merged to mozilla-central, though it didn't get marked, but while http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2015/03/2015-03-11-01-02-31-mozilla-central/mozilla-central-linux64-mulet-nightly-bm77-build1-build15.txt.gz says it used a mozconfig with MOZ_AUTOMATION_UPDATE_PACKAGING=0, it (and all the other Mulet nightlies) still failed while trying to submit its nonexistent update to Balrog.
Assignee

Comment 11

4 years ago
Yeah, the second patch on this bug is for mozharness, which disables trying to send the updates to balrog since we don't need that for mulet. After that, mulet nightlies should be green according to my staging tests.
Comment on attachment 8575442 [details] [diff] [review]
mulet-disable-updates

Review of attachment 8575442 [details] [diff] [review]:
-----------------------------------------------------------------

<stamp>
Attachment #8575442 - Flags: review?(jlund) → review+

Updated

4 years ago
Depends on: 1142335
Assignee

Comment 16

4 years ago
It should, yeah. I'm running that on try now, and if that looks good I'll push an update to inbound to use the latest mozharness.
Assignee

Comment 17

4 years ago
m-c is now using the mozharness fix, so if the next set of mulet nightlies doesn't work, then something else is broken. Please ping me if that's the case!
Assignee

Comment 19

4 years ago
Mulet nightlies are green now, closing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.