Recent contact's name disappears if you call him back with the call log the first time you start the dialer

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gsvelto, Assigned: gsvelto)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=3])

Attachments

(2 attachments)

Assignee

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1135023 +++

STR
Same as bug 1135023 comment 0, but you need to have two SIMs on your phone.

I'm asking for blocking since this issue is essentially the same of a blocking bug.
triage: data loss
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 2

4 years ago
Two quick updates on this. First of all I can reproduce the issue only if the call log is not populated when I launch the app, like after a reset-gaia. Emptying the call log is not enough to trigger it. The second thing is that when I close and re-open the app the call log is properly populated so we're not losing data; the correct entry is being written into the database but not displayed correctly before closing the app.
Assignee

Updated

4 years ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Assignee

Comment 3

4 years ago
I've confirmed that this problem isn't caused by having two SIMs but rather it happens only the very first time you start the dialer with an unpopulated database. Changing the title to reflect this.
Summary: Recent contact's name disappears if you call him back with the call log when two SIMs are installed → Recent contact's name disappears if you call him back with the call log the first time you start the dialer
Assignee

Comment 5

4 years ago
Comment on attachment 8576304 [details] [review]
[gaia] gabrielesvelto:bug-1141578-validate-contact-cache-first-start > mozilla-b2g:master

One line fix and hopefully the last fix for the fallout of the call log db refactoring.
Attachment #8576304 - Flags: review?(thills)
Comment on attachment 8576304 [details] [review]
[gaia] gabrielesvelto:bug-1141578-validate-contact-cache-first-start > mozilla-b2g:master

Looks good and I did test it out as well.
Attachment #8576304 - Flags: review?(thills) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 8

4 years ago
Comment on attachment 8576304 [details] [review]
[gaia] gabrielesvelto:bug-1141578-validate-contact-cache-first-start > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1112577
[User impact] if declined: The call log exhibits erratic behavior when creating and modifying contacts the very first time it's run on a newly formatted phone, with entries appearing either as a number when they should display the name or as the wrong name
[Testing completed]: Tested on a device
[Risk to taking this patch] (and alternatives if risky): This patch is low risk and it addresses the other obvious regression from bug 1112577 besides bug 1135023; the alternative is backing out bug 1112577
[String changes made]: None
Attachment #8576304 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8576304 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This bug has been successfully verified on latest Flame v2.2&3.0.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5.

STR:
1.Flash build
2.Insert two SIM cards.
3.Open Phone app.
4.Input some number on keypad.
5.Call out and end call.
6.Long tap on the number in call log tab, then create a new contact.
7.From the call log, tap on the contact to call again.
**After user end call and back to call log,the recent contact's first name does not disappear.

Flame 2.2 (Pass):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Pass):
Build ID               20150316160204
Gaia Revision          4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gaia Date              2015-03-14 18:50:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.193248
Firmware Date          Mon Mar 16 19:32:58 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.