<td valign="bottom"> does not work

VERIFIED DUPLICATE of bug 22274

Status

()

Core
Layout
--
major
VERIFIED DUPLICATE of bug 22274
17 years ago
17 years ago

People

(Reporter: morpheus, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

The valign="bottom" attribute on the <td> tag does not push the contents of the
<td> container to the bottom as expected.


Reproducible: Always
Steps to Reproduce:
1.Cut and paste the html below into a file:

<html><body>
<table border="0" cellpadding="0" cellspacing="0" bgcolor="#ff0000">
<tr>
<td valign="bottom"><img src="http://www.mozilla.org/images/mozilla-banner.gif"
border="0" /></td>
</tr>
</table>
</body></html>

2.View the file.


Actual Results:  Notice the green bar below the image.  Bad!  The green is from
the background of the table.

Expected Results:  There should be no green visible from the background of the
table.

Comment 1

17 years ago
Created attachment 60916 [details]
user's testcase

Comment 2

17 years ago
Created attachment 60917 [details]
(partial) screendump showing correct layout

WFM, i.e. no green bar below the image. Build ID: 2001 12 06 03. Windows 2000.

Reporter: Could you please try a later build?

Comment 3

17 years ago
WFM, win98SE, 2001120504 
also WFM, win98, 2001112009

(Reporter)

Comment 4

17 years ago
Having trouble testing with a more recent build.  The nightly build's zip file 
seems to be incomplete.  It's been like that for the past two days.  Am I the 
only one who has noticed this?  The tree looks green...
(Reporter)

Comment 5

17 years ago
Created attachment 61181 [details]
Update test case with DOCTYPE tag

Update HTML test case with DOCTYPE tag.
(Reporter)

Comment 6

17 years ago
Tested with Build 2001112009 and 2001121003 on Windows XP.

Looks like I didn't give you the right test case.  I've added a new test case
that adds the DOCTYPE tag (using the Transitional DTD).  The green bar is
showing up now.

If using the Transitional DTD means some tag parameters are now obsolete, is
there a list somewhere I can look up?  Is there CSS solution to this problem? 
I've tried using the CSS margin and padding properties (setting them to 0) to no
success.
The css solution is to set the image to display:block or vertical-align:bottom.

see bug 22274 for all the gory details.

This is correct behavior, not a bug.

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

17 years ago
So what exactly is the point of using the Transitional DOCTYPE then if I'm just 
bumped into Strict anyway?
morpheus, no you are not bumped into strict.  It is transitional but we follow
the standards.  By using that doctype you are forced into complying with the
standards (since that's what the doctype says you are doing anyway).

See http://mozilla.org/docs/web-developer/quirks/doctypes.html for more
information on Quirks vs. Standards mode.  (Not the same as strict vs transitional)

Verify dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.