Total build bustage when Gecko 39 merges to Aurora

VERIFIED FIXED in Firefox 40

Status

()

defect
--
blocker
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: glandium)

Tracking

Trunk
mozilla39
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 disabled, firefox40 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
[Tracking Requested - why for this release]: Complete build bustage when Gecko 39 merges to Aurora.

bz was hitting this locally as well when trying to reproduce test failures I was hitting on an uplift simulation Try push from yesterday. Something keying off NIGHTLY_BUILD that breaks when it isn't defined? This blocks me from running uplift simulation pushes, so please take a look ASAP.

https://treeherder.mozilla.org/logviewer.html#?job_id=5530249&repo=try

In file included from /builds/slave/try-and-api-9-0000000000000000/build/obj-firefox/memory/mozalloc/Unified_cpp_memory_mozalloc0.cpp:2:0:
/builds/slave/try-and-api-9-0000000000000000/build/memory/mozalloc/mozalloc.cpp:29:26: fatal error: malloc_decls.h: No such file or directory
compilation terminated.
make[5]: *** [Unified_cpp_memory_mozalloc0.o] Error 1
make[4]: *** [memory/mozalloc/target] Error 2
make[4]: *** Waiting for unfinished jobs....
Flags: needinfo?(mh+mozilla)
So the reason this works on nightly is that memory/build/moz.build exports malloc_decls.h if MOZ_REPLACE_MALLOC and we always define MOZ_REPLACE_MALLOC if NIGHTLY_BUILD in configure.in.

So the difference is that in a non-nightly malloc_decls.h is not exported.  

mozalloc.cpp is in memory/mozalloc, not memory/build.  And it didn't use to include malloc_decls.h until bug 868814.
Assignee

Comment 2

4 years ago
Assignee: nobody → mh+mozilla
Flags: needinfo?(mh+mozilla)
Attachment #8575654 - Flags: review?(n.nethercote)
Comment on attachment 8575654 [details] [diff] [review]
Fix bustage from bug 868814 with --disable-replace-malloc

Review of attachment 8575654 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8575654 - Flags: review?(n.nethercote) → review+
Assignee

Comment 5

4 years ago
That's not the end of it. The following happens on windows, now:

mozmemory_wrap.obj : error LNK2019: unresolved external symbol _je_memalign referenced in function __aligned_malloc
mozglue.dll : fatal error LNK1120: 1 unresolved externals
mozmake.exe[5]: *** [mozglue.dll] Error 1120
mozmake.exe[4]: *** [mozglue/build/target] Error 2
mozmake.exe[4]: *** Waiting for unfinished jobs....
Keywords: leave-open
Assignee

Comment 6

4 years ago
That error in comment 5 comes from bug 762449
Comment on attachment 8575739 [details] [diff] [review]
Always export memalign from jemalloc, even on Windows

Review of attachment 8575739 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8575739 - Flags: review?(n.nethercote) → review+
Assignee

Updated

4 years ago
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: leave-open
Resolution: --- → FIXED
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla39
Assignee

Updated

4 years ago
Depends on: 1173683
You need to log in before you can comment on or make changes to this bug.