Intermittent failure in test_sms_contact.py

RESOLVED INVALID

Status

defect
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: martijn.martijn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(2 attachments)

Test test_sms_contact.py has failed in latest master build. The failure seems to have occurred while waiting for a message to be received within the messages app

Traceback (most recent call last):
  File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_sms_contact.py", line 37, in test_sms_contact
    new_message.wait_for_recipients_displayed()
  File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/gaiatest/apps/messages/regions/new_message.py", line 84, in wait_for_recipients_displayed
    *self._receiver_input_locator))))
  File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.0 seconds
AssertionError: False is not true

I ran the automated test locally several times and I was able to reproduce the failure. 
Reproduction rate: 2/20

Reproducing manually? No

Device firmware (base)	L1TC100118D0
Device firmware (date)	10 Mar 2015 01:32:31
Device firmware (incremental)	eng.cltbld.20150310.043222
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	09 Mar 2015 15:11:06
Gaia revision	2fb09da0cb9c
Gecko build	20150310010227
Gecko revision	6686aacf006f
Gecko version	39.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Assignee

Updated

4 years ago
Assignee: nobody → martijn.martijn
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Assignee

Comment 3

4 years ago
This seems to be working for me.  Derek, are you still seeing this is latest trunk build?
Flags: needinfo?(dharris)
This issue is now occurring 100% of the time for me. 10/10 Failures. Adding an attachment of my html report for reference
Flags: needinfo?(dharris) → needinfo?(martijn.martijn)
NI on Derek to update the marionette client to v9 and try again.
Flags: needinfo?(dharris)
Assignee

Comment 7

4 years ago
It's still passing for me here in today's Nightly build.

I noticed that you have used marionette_client-0.8.7, I'm using marionette-client==0.9.
Could you update your marionette-client and see if it's still happening? (do "python setup.py develop" in b2g/gaia_clean/tests/python/gaia-ui-tests )
If you can still reproduce, could you verify that you can send sms manually on that device?
Yes, now that I have the marionette client fully updated, it seems to be passing 10/10. Sorry about the confusion.
Flags: needinfo?(dharris)
Assignee

Comment 9

4 years ago
Ok, let's mark it invalid then.
Thanks for looking.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(martijn.martijn)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.