[Settings] Wifi certificate files are not displayed correctly

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: arthurcc, Assigned: arthurcc)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

This bug was regressed by bug 1126708. The patch removed the loading of the module for the panel.
Comment on attachment 8575861 [details] [review]
[gaia] crh0716:1141957 > mozilla-b2g:master

EJ, could you help review this one line patch? It's bad that I did not catch this. Thanks!
Attachment #8575861 - Flags: review?(ejchen)
blocking-b2g: 2.2? → 2.0+
Comment on attachment 8575861 [details] [review]
[gaia] crh0716:1141957 > mozilla-b2g:master

Ahh, I didn't notice that, I thought that was my problem that I didn't have a certificate file to see it in this panel. 

r++, thanks Arthur.
Attachment #8575861 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: 266d58be1b1106952d8b4bbae4048313b01f0685
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0+ → 2.2+
Comment on attachment 8575861 [details] [review]
[gaia] crh0716:1141957 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1126708
[User impact] if declined: Users are not able to import certificate files
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. Adding the line that was removed by mistake
[String changes made]: None
Attachment #8575861 - Flags: approval-gaia-v2.2?
Attachment #8575861 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
I do not have access to a certificate based wifi setup and cannot verify this issue.
QA Whiteboard: [QAnalyst-verify-]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-verify-] → [QAnalyst-verify-][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This bug has been verified as "pass" on the latest nightly build of Flame KK v2.2&2.5 by the STR in comment 0.

Actual results: Wifi certificate files displays correctly, and user can import/select certificate files in Wifi.
See attachment: verified_Flame_v2.2.3gp
Reproduce rate: 0/10


Device: Flame KK 2.2 (Pass)
Build ID               20150804032504
Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gaia Date              2015-07-31 13:20:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0c7a85251e10
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150804.065331
Firmware Date          Tue Aug  4 06:53:43 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Pass)
Build ID               20150804150207
Gaia Revision          c5425d9f1f5184731a59ed4bc99295acbde30390
Gaia Date              2015-08-04 16:09:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f3b757156f69
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150804.184538
Firmware Date          Tue Aug  4 18:45:50 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-verify-][QAnalyst-Triage+] → [QAnalyst-verify-][QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.