Closed Bug 1142040 Opened 5 years ago Closed 2 years ago

CodeGen.py generates a code which could be simplified

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Sylvestre, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: coverity)

Discovered by coverity, 
In the generated file HTMLAllCollectionBinding.cpp, line 958 we have:

deleteSucceeded = !found;
if (found) {
      return deleteSucceeded ? opresult.succeed() : opresult.failCantDelete();
}

The operation opresult.succeed() won't be executed.

That is no big deal at all but we could improve that in order to simplify the generated code.
Maybe a good first bug?
Keywords: coverity
Maaaybe.  The problem is that simplifying this involves making the code generator more complex: the place where deleteSucceeded is assigned is quite far away from the place where it's used in code generator terms.
I am now ignoring them (by hand) in coverity.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.