Closed Bug 1142100 Opened 5 years ago Closed 5 years ago

[Windows Management][Notifications] Tapping on a screenshot notification gives the error message "Image is invalid or corrupt and cannot be displayed"

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-master --- verified

People

(Reporter: jmitchell, Assigned: eeejay)

References

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files, 1 obsolete file)

Description:
Tapping on screenshot notification to be taken to the preview is broken. This  occurs with both the notification banner, and the notification in the notification menu.


Repro Steps:
1) Update a Flame to 20150311010231
2) Take a screenshot and tap on the notification banner

Actual:
Error message

Expected:
Taken to screenshot preview 

Environmental Variables:
Device: Flame Master
Build ID: 20150311010231
Gaia: 943c8b4039f59b08ba100390e164a076a20c892e
Gecko: fd8e079d6335
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency:7/7
Link to failed test case: https://moztrap.mozilla.org/manage/case/14645/
See attached: logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression of a core feature failing the smoke tests.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
This issue also occurs with bluetooth image transfers
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150310113513
Gaia: ca91e1b103a127e991217230f0b3d6083e8a2b87
Gecko: 91a2b8a939fc
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150310122317
Gaia: 9e79bd91b685ab70fa5500a86b401c224c9cdf87
Gecko: edcd95a2b660
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: ca91e1b103a127e991217230f0b3d6083e8a2b87
Gecko: edcd95a2b660

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 9e79bd91b685ab70fa5500a86b401c224c9cdf87
Gecko: 91a2b8a939fc

https://github.com/mozilla-b2g/gaia/compare/ca91e1b103a127e991217230f0b3d6083e8a2b87...9e79bd91b685ab70fa5500a86b401c224c9cdf87

Possibly caused by bug 1068976
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Eitan, can you take a look at this please? Looks like the landing for bug 1068976 might be the cause here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(eitan)
Since this is a smoketest blocker we'll need a backout asap.  Adding qawanted to see if we can bisect those commits to confirm bug 1068976 is the culprit.
Keywords: qaurgent, qawanted
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][backout-asap]
I reverted the commit (https://github.com/mozilla-b2g/gaia/commit/4a1e66705b1053ee7044350b5c207d08b02a4752) from bug 1068976, and the issue no longer reproduced.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
Keywords: qaurgent, qawanted
No-Jun, can you back out the commit in Comment 6 please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(npark)
Flags: needinfo?(pbylenga)
Comment on attachment 8576189 [details] [review]
[gaia] npark-mozilla:1142100 > mozilla-b2g:master

Hi bhavana, this is the backout patch.  since it's my first gaia backout patch, could you make sure I am not doing something strange or missed something?  currently awaiting for the try result.
Flags: needinfo?(npark)
Attachment #8576189 - Flags: review?(bbajaj)
Attachment #8576189 - Flags: review?(bbajaj) → review-
Attachment #8576189 - Attachment is obsolete: true
Actually, I should have pinged the dev to perform the backout according the qa backout process. eeejay, could you look into this please?  Thanks!
I am reproducing now, and will post something for review very soon.
Flags: needinfo?(eitan)
Assignee: nobody → eitan
Attachment #8576234 - Flags: review?(dflanagan)
Attachment #8576234 - Flags: review?(dflanagan) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
https://github.com/mozilla-b2g/gaia/commit/9db5680797c506ff5be880bf8dd87dd468c95060
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Adding qawanted to verify the backout with the next nightly mozilla-central.
Whiteboard: [3.0-Daily-Testing][backout-asap] → [3.0-Daily-Testing]
Blocks: 1142160
QA Contact: bzumwalt
Issue verified fixed on Flame 3.0 Nightly

Tapping on screenshot notification opens screenshot image correctly with no error message. While the screenshot taken can be affected by bug 1142550, it does not appear to be enough to block verification of this issue.

Device: Flame 3.0
Build ID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Moving the bug to the component where the regression came from.
Component: Gaia::System::Window Mgmt → Gaia::Gallery
blocking-b2g: 2.5? → 2.5+
You need to log in before you can comment on or make changes to this bug.