./mach web-platform-tests fails

NEW
Unassigned

Status

Testing
web-platform-tests
--
major
3 years ago
3 years ago

People

(Reporter: sydpolk, Unassigned)

Tracking

39 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I tried the following from a recent checkout and build of mozilla-central:

% ./mach web-platform-tests
 0:00.53 LOG: MainThread INFO Using 1 client processes
 0:02.87 SUITE_START: MainThread 44
 0:02.87 LOG: MainThread INFO Running testharness tests
 0:02.87 TEST_START: MainThread /media-source/mediasource-append-buffer.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-config-change-mp4-a-bitrate.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-duration.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-getvideoplaybackquality.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-play-then-seek-back.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-play.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-seek-beyond-duration.html
 0:02.87 TEST_END: MainThread SKIP
 0:02.87 TEST_START: MainThread /media-source/mediasource-seek-during-pending-seek.html
 0:02.87 TEST_END: MainThread SKIP
 0:03.06 LOG: Thread-TestrunnerManager-1 INFO Setting up ssl
 0:03.07 LOG: Thread-TestrunnerManager-1 WARNING Failure during init Traceback (most recent call last):
  File "c:\dev\mozilla\mozilla-central\testing/web-platform/harness\wptrunner\testrunner.py", line 347, in init
    self.browser.start()
  File "c:\dev\mozilla\mozilla-central\testing/web-platform/harness\wptrunner\browsers\firefox.py", line 108, in start
    self.setup_ssl()
  File "c:\dev\mozilla\mozilla-central\testing/web-platform/harness\wptrunner\browsers\firefox.py", line 216, in setup_ssl
    certutil("-N", "-d", cert_db_path, "-f", pw_path)
  File "c:\dev\mozilla\mozilla-central\testing/web-platform/harness\wptrunner\browsers\firefox.py", line 205, in certutil
    stderr=subprocess.STDOUT),
  File "c:\mozilla-build\python\lib\subprocess.py", line 568, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "c:\mozilla-build\python\lib\subprocess.py", line 711, in __init__
    errread, errwrite)
  File "c:\mozilla-build\python\lib\subprocess.py", line 948, in _execute_child
    startupinfo)
TypeError: environment can only contain strings

etc...

This works fine on Mac OS X.
You need to log in before you can comment on or make changes to this bug.