[Shinano][Aries] FTU and other video playback crash in libmmparser.so

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: daleharvey, Unassigned)

Tracking

({dogfood})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
STR

1. Visit http://well.blogs.nytimes.com/projects/workouts/
2. Install via the popup
3. Begin a Scientific workout

I believe this app requests a screenlock, may be the issue
I see something similar when I scroll down to the bottom of articles on http://m.leparisien.fr
Created attachment 8577191 [details]
libmmparser.so crash
Removing libmmparser.so gets rid of the crash and I don't see any loss of features. No idea of the consequences.
(Reporter)

Comment 5

4 years ago
Confirmed that also fixed the crash for me, also not sure of what the repercussions are.
Michael, do you know if we can safely remove libmmparser.so like we did for libwvm.so ?
Flags: needinfo?(mwu)

Comment 7

4 years ago
No idea. Sounds like a bad idea. I think deeper digging is required to really know.
Flags: needinfo?(mwu)
Created attachment 8585417 [details]
logcat output

That's what happens in logcat when reproducing the crash.
Created attachment 8585428 [details]
logcat output on Flame

Logcat at the same point on my Flame
Comparing attachment 8585417 [details] and attachment 8585428 [details] it looks like we have something going on.

On Z3/Z3 Compact:
> 03-30 13:01:37.100  3634  3915 E MM_OSAL : FileSource::OpenFile iStreamPort
> 03-30 13:01:37.100  3634  3915 E MM_OSAL : FileSource::OpenFile iStreamPort Cur State 1
> 03-30 13:01:37.100  3634  3915 E MM_OSAL : FileSource::OpenFile iStreamPort status 0
> 03-30 13:01:37.100  3634  3931 E MM_OSAL : FileSource::SourceThread received OPEN_FILE_EVENT
> 03-30 13:01:37.100  3634  3931 E MM_OSAL : FileSource::HandleOpenFileCommand
> 03-30 13:01:37.100  3634  3931 E MM_OSAL : FileSource::ValidateMediaHandles
> 03-30 13:01:37.100  3634  3931 E MM_OSAL : FileSource::HandleOpenFileCommand reporting OPEN_FAIL

While on Flame:
> 03-30 13:23:23.520  2053  2126 E MM_OSAL : FileSource::OpenFile iStreamPort
> 03-30 13:23:23.520  2053  2126 E MM_OSAL : FileSource::OpenFile iStreamPort Cur State 1
> 03-30 13:23:23.520  2053  2128 E MM_OSAL : FileSource::SourceThread received OPEN_FILE_EVENT
> 03-30 13:23:23.520  2053  2128 E MM_OSAL : FileSource::HandleOpenFileCommand
> 03-30 13:23:23.520  2053  2128 E MM_OSAL : m_pCriticalSection created..
> 03-30 13:23:23.520  2053  2126 E MM_OSAL : FileSource::OpenFile iStreamPort status 0
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : Mpeg4File::peekMetaDataSize m_minOffsetRequired = 20607
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : Mpeg4File::parseMetaData Parser State = Common::PARSER_RESUME
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : Mpeg4File::ParseStream Parser State = PARSER_READY
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : m_pVideoCriticalSection created..
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : FileSource::HandleOpenFileCommand calling selectDefaultTracks
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : FileSource::selectDefaultTracks m_videoTrackInfo[0].id 1
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : Reading first valid sampleInfo. SampleId=0
> 03-30 13:23:23.530  2053  2128 E MM_OSAL : FileSource::HandleOpenFileCommand reporting OPEN_COMPLETE

Mike, do you have any idea on this?
Flags: needinfo?(mhabicher)
Sotaro might know. libmmparser.so seems to be a vendor provided library. 

It looks like libmmparser.so has multimedia parser stuff in it (based on the symbols). I see stuff like MP3, AVI, ASF, MP4, and a bunch of other codecs.
Duplicate of this bug: 1140595
Summary: nytimes workout app crashes on aries → [Shinano][Aries] Some video playback crash in libmmparser.so
De-ni?-ing myself per IRC conversation.
Flags: needinfo?(mhabicher)
Summary: [Shinano][Aries] Some video playback crash in libmmparser.so → [Shinano][Aries] FTU and other video playback crash in libmmparser.so
Keywords: dogfood
What are the next steps here?
(In reply to Gregor Wagner [:gwagner] from comment #14)
> What are the next steps here?

We need someone that knows the media playback code to help us.
ajones, can your team help out here?
Flags: needinfo?(ajones)

Comment 17

4 years ago
Hi Blake,
Can you take a look? Thanks.
Flags: needinfo?(ajones) → needinfo?(bwu)
Yeah. I can check it.
IIRC, libmmparser is added and used by CAF, so it may need CAF's help to look into. 
Anyway I will try to repro this problem tomorrow.
Flags: needinfo?(bwu)
After syncing the latest codes, I *failed* to repro this problem via launching FTU in "Settings" -> "Developer" for 10 times.

Thanks to jolin's help, I did see this problem with jolin's device with older codes. 
However, the video is not playing smooth in FTU and video app either.
Since the patch Bug 1146729 is landed recently, currently all the mp4 files will be played via MP4Reader which uses gecko's mp4 demuxer adopted from libstagefright. Therefore, libmmparser.so will not be used. 
I has created the bug 1153755 for intermittent playback.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Crash Signature: [@ _ZN7android10SourcePort16GetContentLengthEPx ]
You need to log in before you can comment on or make changes to this bug.