[maildir] Error message popup/alert on startup: "not enough disk space to download new messages" despite sufficient free diskspace available

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: aceman)

Tracking

Trunk
x86
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

Daily and Earlybird 39.0a1/38.0a2 20150313 on Windows 8.1

After setting the storage method for new accounts to maildir (Options > Advanced) and adding a new POP3 account, I occasionally get this error on startup:

"There is not enough disk space to download new messages. Try deleting old mail, emptying the Trash folder, and compacting your mail folders, and then try again."

From the console output of a debug build:

[5436] WARNING: Could not get disk status from nsIDiskSpaceWatcher: file c:\buil
ds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\mozilla\uriloader\prefetch\ns
OfflineCacheUpdateService.cpp, line 321
[5436] WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERR
OR_FAILURE: file c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\mozil
la\storage\src\mozStoragePrivateHelpers.cpp, line 78
[5436] WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERR
OR_FAILURE: file c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\mozil
la\storage\src\mozStoragePrivateHelpers.cpp, line 78
GetDiskSpaceAvailable returned: 13432381440 bytes
GetDiskSpaceAvailable returned: 0 bytes

The GetDiskSpaceAvailable is printed out in two pairs before and there the values in match.

There are already one mbox POP3, an RSS and a NNTP account.

Comment 1

2 years ago
As you wrote "despite sufficient free diskspace available", please elaborate why you think that's the case?
Because Windows Explorer shows that I have 12 GB available on that partition.
(Assignee)

Comment 3

2 years ago
I can't seem to reproduce this. I have done a POP3 account on maildir.
There is always a correct value after "GetDiskSpaceAvailable returned:" (about 8GB). Also, I can copy messages (in TB) from another account to this new one. Does that work for you?
(Assignee)

Updated

2 years ago
See Also: → bug 1174485

Updated

2 years ago
Summary: Error message popup/alert on startup: "not enough disk space to download new messages" despite sufficient free diskspace available → [maildir] Error message popup/alert on startup: "not enough disk space to download new messages" despite sufficient free diskspace available
(Assignee)

Updated

2 years ago
Assignee: nobody → acelists
(Assignee)

Comment 4

2 years ago
So this is again Windows, as in bug 1174485.
Aryx, do you still get the problem? Should I make you some debugging patch? I assume the error is always for Inbox and it is shown at startup when TB wants to download new msgs into it?
(Assignee)

Comment 5

2 years ago
Aryx, any news here?
Flags: needinfo?(aryx.bugmail)
Can't reproduce this anymore on latest Daily (and already failed in June with fewer attempts).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aryx.bugmail)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.