Rejoining an existing MUC fails

RESOLVED FIXED

Status

Chat Core
XMPP
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

({regression})

trunk
x86
Mac OS X
regression

Thunderbird Tracking Flags

(thunderbird38+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR
1) Join a MUC
2) Go offline (e.g. /offline) -> MUC is correctly marked as left
3) Go online (e.g. /back)

Expected behaviour:
MUC is rejoined and no longer marked as left.

Actual behaviour:
Second MUC tab opens, both tabs are marked as left.
(Assignee)

Comment 1

3 years ago
Created attachment 8577543 [details] [diff] [review]
rejoinxmpp.diff.diff

The jsProtoHelper change is needed so the tab sees the correct state. I think the current code tried to minimize the number of UI updates (i.e. to avoid the tab showing joining -> left -> joined). Should we complicate jsProtoHelper to only ever send a single update call, just without bugs?
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8577543 - Flags: review?(clokep)
(Assignee)

Comment 2

3 years ago
This is a joining throbber regression, so we should uplift the fix.
status-thunderbird38: --- → affected
tracking-thunderbird38: --- → ?
Keywords: regression
(Assignee)

Comment 3

3 years ago
(In reply to aleth [:aleth] from comment #2)
> This is a joining throbber regression, so we should uplift the fix.

Actually it's not the joining throbber, but bug 1018771 that is to blame.
Comment on attachment 8577543 [details] [diff] [review]
rejoinxmpp.diff.diff

Review of attachment 8577543 [details] [diff] [review]:
-----------------------------------------------------------------

Seems ok by me, and now matches the joining code.
Attachment #8577543 - Flags: review?(clokep) → review+
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/comm-central/rev/58bf649dc212
(Assignee)

Comment 6

3 years ago
Comment on attachment 8577543 [details] [diff] [review]
rejoinxmpp.diff.diff

[Approval Request Comment]
Regression caused by (bug #): 1018771
User impact if declined: broken chatrooms after reconnections
Risk to taking this patch (and alternatives if risky): low
Attachment #8577543 - Flags: approval-comm-aurora?

Comment 7

3 years ago
Comment on attachment 8577543 [details] [diff] [review]
rejoinxmpp.diff.diff

https://hg.mozilla.org/releases/comm-aurora/rev/8c73047cec44
Attachment #8577543 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

3 years ago
status-thunderbird38: affected → fixed
tracking-thunderbird38: ? → +

Comment 8

3 years ago
This bug needs to be marked fixed, but I don't know the conventions in chat for setting the target milestone.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.